Skip to content

← Actionable
Medium, CVSS 6.1amended

LiteLLM: Arbitrary file write via path traversal in Skills archive extraction

CVE-2026-59820GHSA-5jmr-gcrj-2c9q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.83.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI litellm

    Affected
    < 1.83.7
    Fixed in
    1.83.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-59820: 0.59% estimated exploitation activity in the next 30 days; percentile 48.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact LiteLLM Skills archive extraction did not sufficiently validate file paths from uploaded skill ZIP archives. An authenticated user with access to LiteLLM LLM API routes, or a key whose allowedroutes includes /v1/skills, anthropicroutes, or llmapiroutes, could upload a crafted skill archive containing path traversal entries. When the skill was processed for execution, those entries could be written outside the intended extraction/staging directory. This could allow arbitrary file write and may lead to code execution depending on deployment configuration and writable paths. Patches The issue is fixed in 1.83.7-stable. LiteLLM recommens upgrading to 1.83.7-stable or later. Workarounds If upgrading is not immediately possible: 1. Block POST /v1/skills at your reverse proxy or API gateway. 2. Restrict Skills API access to trusted users only.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5jmr-gcrj-2c9q

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5jmr-gcrj-2c9q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59820

Advisory: LiteLLM: Arbitrary file write via path traversal in Skills archive extraction
IDs: CVE-2026-59820, GHSA-5jmr-gcrj-2c9q
Record: https://patchnext.com/advisories/cve-2026-59820 (revision 3, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: litellm 1.83.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI litellm: affected < 1.83.7; fixed in 1.83.7

## Suggested inspection (read-only)
- `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on litellm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5jmr-gcrj-2c9q (OSV record GHSA-5jmr-gcrj-2c9q lists affected ranges: PyPI litellm >=0 <1.83.7 (fixed))
- Verified: https://github.com/advisories/GHSA-5jmr-gcrj-2c9q (GitHub-reviewed advisory GHSA-5jmr-gcrj-2c9q lists affected ranges: PyPI litellm >=0 <1.83.7)

Commands are suggestions: review each one before running it.

Loading voting…