Skip to content

← Actionable
Medium, CVSS 5.3

Ghost: Paid gift memberships obtainable at minimal cost via the donations feature

CVE-2026-59817GHSA-xm43-3m56-w3wf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 6.44.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ghost

    Affected
    >= 6.27.0, < 6.44.0
    Fixed in
    6.44.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-59817: 0.40% estimated exploitation activity in the next 30 days; percentile 34.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability in Ghost's public donation checkout flow allowed an unauthenticated attacker to obtain full paid gift memberships for a minimal payment. No customer or member data was exposed, and the issue could not be used to steal money from a site or its members. Vulnerable versions This vulnerability is present in Ghost from v6.27.0 up to v6.43.1. Patches v6.44.0 contains a fix for this issue. How to update For self-hosters using Docker, find Docker’s official Ghost image on Docker Hub and follow the documentation on updating a Docker-based Ghost instance. For self-hosters using Ghost-CLI, see the documentation for updating Ghost to the latest version. Workarounds If upgrading immediately is not possible, you can remove the vulnerable checkout path by disabling the donations feature in Ghost Admin under Settings → Membership → Tips & donations until the upgrade is applied. References Ghost thanks sane100400 and p4p3r for disclosing this vulnerability responsibly. For more…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xm43-3m56-w3wf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59817

Advisory: Ghost: Paid gift memberships obtainable at minimal cost via the donations feature
IDs: CVE-2026-59817, GHSA-xm43-3m56-w3wf
Record: https://patchnext.com/advisories/cve-2026-59817 (revision 1, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ghost 6.44.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ghost: affected >= 6.27.0, < 6.44.0; fixed in 6.44.0

## Suggested inspection (read-only)
- `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ghost.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xm43-3m56-w3wf (GitHub-reviewed advisory GHSA-xm43-3m56-w3wf lists affected ranges: npm ghost >=6.27.0 <6.44.0)

Commands are suggestions: review each one before running it.

Loading voting…