Skip to content

← Actionable
High, CVSS 7.5amended

Socket.IO: Engine.IO Polling Transport Connection Exhaustion

CVE-2026-59725GHSA-r635-g3xr-vw7x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (engine.io 6.6.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm engine.io

    Affected
    >= 4.1.0, < 6.6.7
    Fixed in
    6.6.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-59725: 0.64% estimated exploitation activity in the next 30 days; percentile 50.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An unauthenticated remote attacker can cause a denial of service in affected versions of engine.io by opening Engine.IO polling sessions and sending an invalid binary POST request with: against an Engine.IO protocol v4 polling transport. In the vulnerable code path, the server reports a transport error but does not properly close the HTTP response associated with the malformed request. As a result, the underlying HTTP connection may remain open, consuming one server-side socket/resource per crafted request. An attacker can repeat this with many sessions to exhaust available HTTP connections, sockets, file descriptors, or related server resources, potentially preventing legitimate clients from connecting. Patches The issue was fixed in: - engine.io 6.6.7 The fix ensures that invalid binary polling POST requests are explicitly rejected with an HTTP response and closed properly. Users should upgrade to: or a later fixed version. If using Socket.IO through the monorepo/packages,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r635-g3xr-vw7x

  2. Revision 1 · created ·

    Published from osv record GHSA-r635-g3xr-vw7x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59725

Advisory: Socket.IO: Engine.IO Polling Transport Connection Exhaustion
IDs: CVE-2026-59725, GHSA-r635-g3xr-vw7x
Record: https://patchnext.com/advisories/cve-2026-59725 (revision 2, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: engine.io 6.6.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm engine.io: affected >= 4.1.0, < 6.6.7; fixed in 6.6.7

## Suggested inspection (read-only)
- `npm ls engine.io --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on engine.io.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r635-g3xr-vw7x (OSV record GHSA-r635-g3xr-vw7x lists affected ranges: npm engine.io >=4.1.0 <6.6.7 (fixed))
- Verified: https://github.com/advisories/GHSA-r635-g3xr-vw7x (GitHub-reviewed advisory GHSA-r635-g3xr-vw7x lists affected ranges: npm engine.io >=4.1.0 <6.6.7)

Commands are suggestions: review each one before running it.

Loading voting…