Skip to content

← Actionable
High, CVSS 7.5

Socket.IO: Engine.IO WebTransport SID DoS

CVE-2026-59724GHSA-gr94-w7qr-f4j3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (engine.io 6.6.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm engine.io

    Affected
    >= 6.5.0, < 6.6.7
    Fixed in
    6.6.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-59724: 0.61% estimated exploitation activity in the next 30 days; percentile 49.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Engine.IO servers with WebTransport enabled are vulnerable to a remotely triggerable denial of service. A malicious unauthenticated client can send a crafted WebTransport upgrade request containing a specially chosen session ID, such as proto. Because the session ID lookup did not properly verify that the key was an own property of the clients object, the lookup could resolve to an inherited prototype property instead of a valid Engine.IO client. This can cause a TypeError during WebTransport upgrade handling. Since the failure occurs in an asynchronous context, it may result in an unhandled Promise rejection and terminate the Node.js process on affected Node.js versions/configurations. Successful exploitation can allow an unauthenticated remote attacker to crash the server process and cause denial of service. Under a process supervisor, repeated exploitation may cause crash loops. Affected configurations are limited to deployments where WebTransport support is enabled.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gr94-w7qr-f4j3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59724

Advisory: Socket.IO: Engine.IO WebTransport SID DoS
IDs: CVE-2026-59724, GHSA-gr94-w7qr-f4j3
Record: https://patchnext.com/advisories/cve-2026-59724 (revision 1, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: engine.io 6.6.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm engine.io: affected >= 6.5.0, < 6.6.7; fixed in 6.6.7

## Suggested inspection (read-only)
- `npm ls engine.io --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on engine.io.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gr94-w7qr-f4j3 (GitHub-reviewed advisory GHSA-gr94-w7qr-f4j3 lists affected ranges: npm engine.io >=6.5.0 <6.6.7)

Commands are suggestions: review each one before running it.

Loading voting…