Skip to content

← Actionable
High, CVSS 8.8amended

Cline: Cross-Origin WebSocket Hijacking in Cline Hub Dashboard (/browser endpoint)

CVE-2026-59723GHSA-3cj3-hqcr-g934

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cline 3.0.30), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm cline

    Affected
    < 3.0.30
    Fixed in
    3.0.30

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-59723: 0.25% estimated exploitation activity in the next 30 days; percentile 16.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Cline Hub dashboard server (@cline/cline-hub), launched via the cline dashboard CLI command, accepts WebSocket connections on the /browser endpoint without validating the HTTP Origin header. When ROOMSECRET is not set—the default for local (127.0.0.1) binds—isAuthorizedBrowserRequest() returns true unconditionally, allowing any website a developer visits to open a cross-origin WebSocket to ws://127.0.0.1:8787/browser. An attacker-controlled page can then send desktopCommand frames to read workspace/session state, mutate MCP and provider settings, and—because dashboard sessions default to autoApprove: true for all tools—trigger arbitrary command execution when a provider/model is configured. Dynamically confirmed: an upsertmcpserver frame injected a malicious stdio MCP server entry into the victim's Cline settings file with ok: true response. Details The vulnerable code path spans multiple files in the apps/cline-hub workspace. No secret by default (local bind)…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3cj3-hqcr-g934

  2. Revision 2 · amended ·

    Amended from osv record GHSA-3cj3-hqcr-g934

  3. Revision 1 · created ·

    Published from ghsa record GHSA-3cj3-hqcr-g934

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59723

Advisory: Cline: Cross-Origin WebSocket Hijacking in Cline Hub Dashboard (`/browser` endpoint)
IDs: CVE-2026-59723, GHSA-3cj3-hqcr-g934
Record: https://patchnext.com/advisories/cve-2026-59723 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cline 3.0.30. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm cline: affected < 3.0.30; fixed in 3.0.30

## Suggested inspection (read-only)
- `npm ls cline --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cline.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3cj3-hqcr-g934 (GitHub-reviewed advisory GHSA-3cj3-hqcr-g934 lists affected ranges: npm cline >=0 <3.0.30)
- Verified: https://osv.dev/vulnerability/GHSA-3cj3-hqcr-g934 (OSV record GHSA-3cj3-hqcr-g934 lists affected ranges: npm cline >=0 <3.0.30 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…