Skip to content

← Actionable
High, CVSS 7.1amended

Open WebUI: Cross-channel message overwrite via chat completion API (single-model and multimodel message_ids)

CVE-2026-59714GHSA-x2ff-v5v8-m75m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI open-webui

    Affected
    >= 0.9.5, < 0.10.0
    Fixed in
    0.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
EPSS
  • CVE-2026-59714: 0.48% estimated exploitation activity in the next 30 days; percentile 41.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Any authenticated user can overwrite the content of a message in a channel they do not belong to (including private and DM channels) by sending a chat completion request with a channel:-prefixed chatid and a target messageid. The channel: path routes pipeline output through makechannelemitter, which writes to the Messages table using the caller-supplied messageid without binding it to the channel. This advisory consolidates two filings of the same flaw: the original single-model form, and a multimodel messageids variant that survives the partial fix shipped in v0.9.6 (see "Fix status" below). Details (as introduced in v0.9.5) When a user submits a chat completion request with a chatid starting with channel:, three authorization gaps combined in v0.9.5: 1. Ownership check skipped (main.py): the channel: prefix caused the entire ownership/membership verification block to be skipped, with no channel membership/write check replacing it. 2. Message ID from user input: id (and each…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x2ff-v5v8-m75m

  2. Revision 1 · created ·

    Published from osv record GHSA-x2ff-v5v8-m75m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59714

Advisory: Open WebUI: Cross-channel message overwrite via chat completion API (single-model and multimodel message_ids)
IDs: CVE-2026-59714, GHSA-x2ff-v5v8-m75m
Record: https://patchnext.com/advisories/cve-2026-59714 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected >= 0.9.5, < 0.10.0; fixed in 0.10.0

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x2ff-v5v8-m75m (OSV record GHSA-x2ff-v5v8-m75m lists affected ranges: PyPI open-webui >=0.9.5 <0.10.0 (fixed))
- Verified: https://github.com/advisories/GHSA-x2ff-v5v8-m75m (GitHub-reviewed advisory GHSA-x2ff-v5v8-m75m lists affected ranges: PyPI open-webui >=0.9.5 <0.10.0)

Commands are suggestions: review each one before running it.

Loading voting…