n8n: External Secrets Permission Bypass via Expression Parser Mismatch
CVE-2026-59259GHSA-jp7m-xcgx-57qm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.28.1, 2.27.4, 1.123.61), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 1.123.61>= 2.28.0, < 2.28.1>= 2.0.0-rc.0, < 2.27.4
- Fixed in
- 2.27.4, 1.123.61, 2.28.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jp7m-xcgx-57qm lists affected ranges: npm n8n >=0 =2.28.0 =2.0.0-rc.0 <2.27.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jp7m-xcgx-57qm lists affected ranges: npm n8n >=0 =2.28.0 =2.0.0-rc.0 <2.27.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-59259: 0.44% estimated exploitation activity in the next 30 days; percentile 38.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Due to a mismatch between the static validation check and the runtime expression engine, an authenticated user with credential create or update permissions, but without the externalSecret:list scope, could embed external secret references into credentials in forms the validation did not detect. These references would resolve at workflow execution time, exposing secret values the user was not authorized to access. This issue only affects instances where an external secrets provider is configured and Advanced Permissions are in use. Patches The issue has been fixed in n8n versions 1.123.61, 2.27.4, and 2.28.1. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict credential creation and update permissions to fully trusted users only. - Audit existing credentials for unexpected external secret references. These…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jp7m-xcgx-57qm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jp7m-xcgx-57qm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59259 Advisory: n8n: External Secrets Permission Bypass via Expression Parser Mismatch IDs: CVE-2026-59259, GHSA-jp7m-xcgx-57qm Record: https://patchnext.com/advisories/cve-2026-59259 (revision 3, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.28.1, 2.27.4, 1.123.61. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 1.123.61; >= 2.28.0, < 2.28.1; >= 2.0.0-rc.0, < 2.27.4; fixed in 2.27.4, 1.123.61, 2.28.1 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jp7m-xcgx-57qm (OSV record GHSA-jp7m-xcgx-57qm lists affected ranges: npm n8n >=0 =2.28.0 =2.0.0-rc.0 <2.27.4 (fixed)) - Verified: https://github.com/advisories/GHSA-jp7m-xcgx-57qm (GitHub-reviewed advisory GHSA-jp7m-xcgx-57qm lists affected ranges: npm n8n >=0 =2.28.0 =2.0.0-rc.0 <2.27.4) Commands are suggestions: review each one before running it.
Loading voting…