Skip to content

← Actionable
Medium, CVSS 4.3amended

Open WebUI: POST /api/v1/images/edit bypasses the global image-edit switch and the per-user image-generation permission

CVE-2026-59227GHSA-rqj7-6wrp-6g2g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI open-webui

    Affected
    >= 0.8.11, < 0.10.0
    Fixed in
    0.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-59227: 0.42% estimated exploitation activity in the next 30 days; percentile 36.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary POST /api/v1/images/edit performed no authorization beyond requiring a verified account. Every other image-editing surface in Open WebUI enforces the global image-edit switch and the per-user image-generation permission — the /api/v1/images/generations route, the built-in editimage tool, and the chat image-edit middleware — but the direct edit route enforced neither. A verified non-admin user could therefore invoke server-side image editing, reaching the configured image-edit provider with the administrator's credentials, even when the administrator had globally disabled image editing (ENABLEIMAGEEDIT=False) or denied that user image-generation permission. The image-editing UI is surfaced only to administrators (Playground), so the route additionally exposed an admin-only capability to any verified user. Impact An authenticated, non-admin user can: - bypass the global ENABLEIMAGEEDIT=False administrator control; - bypass a denied per-user/group features.imagegeneration…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rqj7-6wrp-6g2g

  2. Revision 1 · created ·

    Published from osv record GHSA-rqj7-6wrp-6g2g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59227

Advisory: Open WebUI: POST /api/v1/images/edit bypasses the global image-edit switch and the per-user image-generation permission
IDs: CVE-2026-59227, GHSA-rqj7-6wrp-6g2g
Record: https://patchnext.com/advisories/cve-2026-59227 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected >= 0.8.11, < 0.10.0; fixed in 0.10.0

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rqj7-6wrp-6g2g (OSV record GHSA-rqj7-6wrp-6g2g lists affected ranges: PyPI open-webui >=0.8.11 <0.10.0 (fixed))
- Verified: https://github.com/advisories/GHSA-rqj7-6wrp-6g2g (GitHub-reviewed advisory GHSA-rqj7-6wrp-6g2g lists affected ranges: PyPI open-webui >=0.8.11 <0.10.0)

Commands are suggestions: review each one before running it.

Loading voting…