Open WebUI: Cross-user code-interpreter and tool execution via unvalidated Socket.IO event-caller session_id
CVE-2026-59216GHSA-74h3-cxq7-vc5q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI open-webui
- Affected
- < 0.10.0
- Fixed in
- 0.10.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-74h3-cxq7-vc5q lists affected ranges: PyPI open-webui >=0 <0.10.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-74h3-cxq7-vc5q lists affected ranges: PyPI open-webui >=0 <0.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-59216: 0.45% estimated exploitation activity in the next 30 days; percentile 39.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An authenticated low-privilege user can execute arbitrary code-interpreter Python and tools inside another user's authenticated session. The Socket.IO event-caller (geteventcall) delivers execute:python / execute:tool events to a client-supplied sessionid after only checking that the session is connected, never that it belongs to the requester. Combined with ydoc:document:join, which exposes the live socket ids of everyone in a shared note's collaboration room to any read-access participant, an attacker can target a victim's session and run attacker-chosen code/tools in the victim's browser context. When the victim is an administrator, that hijacked context reaches the admin-only Functions API, whose source is executed server-side, yielding remote code execution as the server process (root in the default container). Affected component - backend/openwebui/socket/main.py — geteventcall() / eventcaller - backend/openwebui/main.py — chat-completion metadata (sessionid taken from…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-74h3-cxq7-vc5q
- Revision 1 · created ·
Published from osv record GHSA-74h3-cxq7-vc5q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59216 Advisory: Open WebUI: Cross-user code-interpreter and tool execution via unvalidated Socket.IO event-caller session_id IDs: CVE-2026-59216, GHSA-74h3-cxq7-vc5q Record: https://patchnext.com/advisories/cve-2026-59216 (revision 2, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: open-webui 0.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI open-webui: affected < 0.10.0; fixed in 0.10.0 ## Suggested inspection (read-only) - `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on open-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-74h3-cxq7-vc5q (OSV record GHSA-74h3-cxq7-vc5q lists affected ranges: PyPI open-webui >=0 <0.10.0 (fixed)) - Verified: https://github.com/advisories/GHSA-74h3-cxq7-vc5q (GitHub-reviewed advisory GHSA-74h3-cxq7-vc5q lists affected ranges: PyPI open-webui >=0 <0.10.0) Commands are suggestions: review each one before running it.
Loading voting…