Skip to content

← Actionable
High, CVSS 7.3amended

Open WebUI: Stored web worker XSS via Pyodide

CVE-2026-59214GHSA-4r2p-27mh-5m22

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-59214: 0.42% estimated exploitation activity in the next 30 days; percentile 36.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Title: Same-origin Pyodide code execution allows server-side RCE via a shared chat Summary Open WebUI runs client-side Python (Pyodide) in a same-origin web worker. Through Pyodide's JavaScript API (pyodide.http.pyfetch, or the js module which exposes the page's fetch / XMLHttpRequest) executed Python can issue requests on the application origin, and those requests carry the victim's session cookie. A low-privileged user can store such a payload in a chat message, share the chat, and when a victim opens it and clicks Run the payload executes authenticated same-origin requests as the victim. When the victim is an admin (or a user holding workspace.functions / workspace.tools permissions) the payload creates a Function/Tool whose body runs server-side, yielding remote code execution. Details Pyodide's js bridge gives Python in the worker the same reach as inline JavaScript on the origin, and the worker is same-origin, so a credentialed request to the app's own API is authenticated as…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4r2p-27mh-5m22

  2. Revision 1 · created ·

    Published from osv record GHSA-4r2p-27mh-5m22

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59214

Advisory: Open WebUI: Stored web worker XSS via Pyodide
IDs: CVE-2026-59214, GHSA-4r2p-27mh-5m22
Record: https://patchnext.com/advisories/cve-2026-59214 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected < 0.10.0; fixed in 0.10.0

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4r2p-27mh-5m22 (OSV record GHSA-4r2p-27mh-5m22 lists affected ranges: PyPI open-webui >=0 <0.10.0 (fixed))
- Verified: https://github.com/advisories/GHSA-4r2p-27mh-5m22 (GitHub-reviewed advisory GHSA-4r2p-27mh-5m22 lists affected ranges: PyPI open-webui >=0 <0.10.0)

Commands are suggestions: review each one before running it.

Loading voting…