Skip to content

← Actionable
Medium, CVSS 5.4amended

Open WebUI: Model meta.knowledge read-only file access can be upgraded to file write/delete

CVE-2026-59212GHSA-2xwm-4h2q-ggfx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI open-webui

    Affected
    >= 0.9.6, < 0.10.0
    Fixed in
    0.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
EPSS
  • CVE-2026-59212: 0.42% estimated exploitation activity in the next 30 days; percentile 36.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Current main and v0.9.6 still allow an authenticated user to turn read-only access to another user's file into write/delete access by attaching that file ID to an attacker-controlled workspace model. This is an incomplete-fix variant of GHSA-vjqm-6gcc-62cr. The current fix adds verifyknowledgefileaccess(), but the validator only checks hasaccesstofile(fileid, "read", user). The file write/delete routes later trust hasaccesstofile(fileid, "write", user), and that function grants access through any writable model whose meta.knowledge contains the file ID. The PoV includes a negative control showing the current validator rejects an inaccessible arbitrary file ID. The residual issue is narrower: a file ID that is readable only through a KB read grant is accepted into direct model file metadata, then the same model metadata satisfies later file write/delete checks. Technical Details backend/openwebui/routers/models.py::verifyknowledgefileaccess() accepts model meta.knowledge file…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2xwm-4h2q-ggfx

  2. Revision 1 · created ·

    Published from osv record GHSA-2xwm-4h2q-ggfx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59212

Advisory: Open WebUI: Model meta.knowledge read-only file access can be upgraded to file write/delete
IDs: CVE-2026-59212, GHSA-2xwm-4h2q-ggfx
Record: https://patchnext.com/advisories/cve-2026-59212 (revision 2, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected >= 0.9.6, < 0.10.0; fixed in 0.10.0

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2xwm-4h2q-ggfx (OSV record GHSA-2xwm-4h2q-ggfx lists affected ranges: PyPI open-webui >=0.9.6 <0.10.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2xwm-4h2q-ggfx (GitHub-reviewed advisory GHSA-2xwm-4h2q-ggfx lists affected ranges: PyPI open-webui >=0.9.6 <0.10.0)

Commands are suggestions: review each one before running it.

Loading voting…