Skip to content

← Actionable
High, CVSS 7.1amended

n8n: Prototype Pollution via Workflow Credentials Leads to Unauthenticated User and Project Enumeration

CVE-2026-59206GHSA-75qm-gp28-rcq9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.28.1, 2.27.4, 1.123.61), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    < 1.123.61>= 2.28.0, < 2.28.1>= 2.0.0-rc.0, < 2.27.4
    Fixed in
    2.27.4, 1.123.61, 2.28.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-59206: 0.66% estimated exploitation activity in the next 30 days; percentile 51.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated user with the default workflow:create permission could pollute Object.prototype through a crafted workflow saved, updated, or imported via the workflow API. This can be leveraged to bypass authentication, allowing unauthenticated requests to be treated as a privileged user and exposing endpoints such as the user and project listings. As a result, every account's personal data (email, role, MFA status) and all projects on the instance may be disclosed to unauthenticated callers. The pollution can also corrupt global state, making parts of the instance unresponsive until restarted. Patches The issue has been fixed in n8n versions 1.123.61, 2.27.4, and 2.28.1. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict workflow creation and editing permissions to fully trusted users only. - Restrict…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-75qm-gp28-rcq9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-75qm-gp28-rcq9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59206

Advisory: n8n: Prototype Pollution via Workflow Credentials Leads to Unauthenticated User and Project Enumeration
IDs: CVE-2026-59206, GHSA-75qm-gp28-rcq9
Record: https://patchnext.com/advisories/cve-2026-59206 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.28.1, 2.27.4, 1.123.61. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected < 1.123.61; >= 2.28.0, < 2.28.1; >= 2.0.0-rc.0, < 2.27.4; fixed in 2.27.4, 1.123.61, 2.28.1

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-75qm-gp28-rcq9 (OSV record GHSA-75qm-gp28-rcq9 lists affected ranges: npm n8n >=0 =2.28.0 =2.0.0-rc.0 <2.27.4 (fixed))
- Verified: https://github.com/advisories/GHSA-75qm-gp28-rcq9 (GitHub-reviewed advisory GHSA-75qm-gp28-rcq9 lists affected ranges: npm n8n >=0 =2.28.0 =2.0.0-rc.0 <2.27.4)

Commands are suggestions: review each one before running it.

Loading voting…