Skip to content

← Actionable
High, CVSS 7.5amended

Pillow: Decompression Bomb DoS via PdfParser.PdfStream.decode()

CVE-2026-59200GHSA-jjj6-mw9f-p565

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 12.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pillow

    Affected
    >= 5.1.0, < 12.3.0
    Fixed in
    12.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-59200: 0.39% estimated exploitation activity in the next 30 days; percentile 32.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PdfParser.PdfStream.decode() in Pillow's PdfParser.py calls zlib.decompress() with the bufsize parameter set to the value of the PDF stream's Length field, without any upper bound on the actual decompressed output size. Python's zlib.decompress() bufsize argument is an initial output buffer hint, not a maximum size limit — the function will expand memory until the full decompressed result is produced. A crafted PDF containing a FlateDecode-compressed stream decompresses to 1 GB of memory from a ~950 KB file, causing server OOM termination or severe degradation in any application that uses PdfParser to read untrusted PDF files. Details PdfStream.decode() in pdfminer/PdfParser.py reads the stream's declared Length (or DL) field from the PDF dictionary and passes it as bufsize to zlib.decompress(): From the Python documentation: "The bufsize parameter is used as the initial size of the output buffer." It does not cap decompression. An attacker who controls the PDF stream…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jjj6-mw9f-p565

  2. Revision 1 · created ·

    Published from osv record GHSA-jjj6-mw9f-p565

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59200

Advisory: Pillow: Decompression Bomb DoS via PdfParser.PdfStream.decode()
IDs: CVE-2026-59200, GHSA-jjj6-mw9f-p565
Record: https://patchnext.com/advisories/cve-2026-59200 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pillow 12.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pillow: affected >= 5.1.0, < 12.3.0; fixed in 12.3.0

## Suggested inspection (read-only)
- `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pillow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jjj6-mw9f-p565 (OSV record GHSA-jjj6-mw9f-p565 lists affected ranges: PyPI pillow >=5.1.0 <12.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-jjj6-mw9f-p565 (GitHub-reviewed advisory GHSA-jjj6-mw9f-p565 lists affected ranges: PyPI pillow >=5.1.0 <12.3.0)

Commands are suggestions: review each one before running it.

Loading voting…