Skip to content

← Actionable
High, CVSS 8.2amended

pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config

CVE-2026-59195GHSA-qrv3-253h-g69c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 11.8.0, 10.34.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm pnpm

    Affected
    < 10.34.4>= 11.0.0, < 11.8.0
    Fixed in
    10.34.4, 11.8.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:L
EPSS
  • CVE-2026-59195: 0.40% estimated exploitation activity in the next 30 days; percentile 34.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary pnpm accepts package names from the env lockfile configDependencies section and uses those names directly when creating config dependency symlinks under nodemodules/.pnpm-config. A malicious repository can commit a crafted pnpm-lock.yaml whose env-lockfile document contains a traversal-shaped config dependency name such as ../../PWNEDCFGDEP. During pnpm install, pnpm installs the config dependency and creates a symlink at a path derived from that name. In local testing against pnpm v11.5.1, this caused pnpm to create a symlink outside the intended config dependency directory: This works with --ignore-scripts, so it does not rely on lifecycle script execution. Vulnerable behavior The vulnerable behavior appears to be that configDependencies keys from the env lockfile are trusted as package names and used in filesystem paths without rejecting traversal components. The relevant pattern is: If pkgName is attacker-controlled and contains .., then path.join(configModulesDir,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qrv3-253h-g69c

  2. Revision 1 · created ·

    Published from osv record GHSA-qrv3-253h-g69c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59195

Advisory: pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config
IDs: CVE-2026-59195, GHSA-qrv3-253h-g69c
Record: https://patchnext.com/advisories/cve-2026-59195 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pnpm 11.8.0, 10.34.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pnpm: affected < 10.34.4; >= 11.0.0, < 11.8.0; fixed in 10.34.4, 11.8.0

## Suggested inspection (read-only)
- `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pnpm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qrv3-253h-g69c (OSV record GHSA-qrv3-253h-g69c lists affected ranges: npm pnpm >=0 =11.0.0 <11.8.0 (fixed))
- Verified: https://github.com/advisories/GHSA-qrv3-253h-g69c (GitHub-reviewed advisory GHSA-qrv3-253h-g69c lists affected ranges: npm pnpm >=0 =11.0.0 <11.8.0)

Commands are suggestions: review each one before running it.

Loading voting…