Skip to content

← Actionable
High, CVSS 7.1amended

pnpm: patch-remove could delete project-selected files outside the patches directory

CVE-2026-59194GHSA-72r4-9c5j-mj57

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 11.7.0, 10.34.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm pnpm

    Affected
    < 10.34.4>= 11.0.0, < 11.7.0
    Fixed in
    10.34.4, 11.7.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:L
EPSS
  • CVE-2026-59194: 0.40% estimated exploitation activity in the next 30 days; percentile 34.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The patch-remove deletion-scope issue tracked as GHSA-72r4-9c5j-mj57 / CAND-PNPM-030 has been addressed in pnpm. A crafted patch entry could resolve outside the configured patches directory and cause pnpm patch-remove to delete an arbitrary reachable file. This patch validates the configured directory and every resolved target before unlinking anything, then deletes the final directory entry without following it. Security boundary - Traversal and absolute paths that resolve outside the configured patches directory are rejected before deletion. - Parent directories are canonicalized before deletion, including the case where a nested symlink points outside and the final outside entry is itself dangling. - The complete batch is validated before any file is removed. - Component-aware predicates accept valid names beginning with .. while still rejecting parent traversal, Windows drive escapes, and UNC escapes. - Valid files and symlinked patch directories whose canonical targets…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-72r4-9c5j-mj57

  2. Revision 1 · created ·

    Published from osv record GHSA-72r4-9c5j-mj57

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59194

Advisory: pnpm: `patch-remove` could delete project-selected files outside the patches directory
IDs: CVE-2026-59194, GHSA-72r4-9c5j-mj57
Record: https://patchnext.com/advisories/cve-2026-59194 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pnpm 11.7.0, 10.34.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pnpm: affected < 10.34.4; >= 11.0.0, < 11.7.0; fixed in 10.34.4, 11.7.0

## Suggested inspection (read-only)
- `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pnpm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-72r4-9c5j-mj57 (OSV record GHSA-72r4-9c5j-mj57 lists affected ranges: npm pnpm >=0 =11.0.0 <11.7.0 (fixed))
- Verified: https://github.com/advisories/GHSA-72r4-9c5j-mj57 (GitHub-reviewed advisory GHSA-72r4-9c5j-mj57 lists affected ranges: npm pnpm >=0 =11.0.0 <11.7.0)

Commands are suggestions: review each one before running it.

Loading voting…