Apprise forwards configured auth headers across cross-origin HTTP redirects
CVE-2026-59180GHSA-856c-92hv-3vxx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apprise 1.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apprise
- Affected
- <= 1.10.0
- Fixed in
- 1.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-856c-92hv-3vxx lists affected ranges: PyPI apprise >=0 <=1.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-856c-92hv-3vxx lists affected ranges: PyPI apprise >=0 <1.11.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-59180: 0.30% estimated exploitation activity in the next 30 days; percentile 22.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Apprise's HTTP-based notification plugins and its HTTP attachment / config loaders (apprise/attachment/http.py, apprise/config/http.py) follow HTTP 3xx redirects by default and re-send the user-configured auth headers and query parameters on the redirected request. If an operator-configured destination is later compromised (service takeover, malicious update), or an attacker holds a MITM position on an unprotected network path, that destination can return a 302 Location: to an arbitrary host and Apprise forwards the user's secret (X-Gotify-Key, Authorization, bearer tokens in query, custom +Header= values) to that cross-origin host. The attacker does not need to control the original Apprise URL — only the response from a destination the operator already trusts. This is the application-layer analogue of urllib3 GHSA-34jh-p97f-mpxf / CVE-2026-44431 ("Proxy-Authorization forwarded across cross-origin redirect"). Affected versions All releases up to and including v1.10.0 (latest…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-856c-92hv-3vxx
- Revision 2 · amended ·
Amended from osv record GHSA-856c-92hv-3vxx
- Revision 1 · created ·
Published from ghsa record GHSA-856c-92hv-3vxx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59180 Advisory: Apprise forwards configured auth headers across cross-origin HTTP redirects IDs: CVE-2026-59180, GHSA-856c-92hv-3vxx Record: https://patchnext.com/advisories/cve-2026-59180 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apprise 1.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apprise: affected <= 1.10.0; fixed in 1.11.0 ## Suggested inspection (read-only) - `python -m pip show apprise`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apprise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-856c-92hv-3vxx (GitHub-reviewed advisory GHSA-856c-92hv-3vxx lists affected ranges: PyPI apprise >=0 <=1.10.0) - Verified: https://osv.dev/vulnerability/GHSA-856c-92hv-3vxx (OSV record GHSA-856c-92hv-3vxx lists affected ranges: PyPI apprise >=0 <1.11.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…