@openhop/server: Path Traversal in Flow ID File Operations
CVE-2026-59179GHSA-g72f-jw3w-mgh7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openhop/server 0.3.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @openhop/server
- Affected
- <= 0.3.5
- Fixed in
- 0.3.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g72f-jw3w-mgh7 lists affected ranges: npm @openhop/server >=0 <=0.3.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g72f-jw3w-mgh7 lists affected ranges: npm @openhop/server >=0 <0.3.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:H
- EPSS
- CVE-2026-59179: 0.39% estimated exploitation activity in the next 30 days; percentile 33.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Path Traversal in Flow ID File Operations Summary @openhop/server passes unsanitized HTTP route parameters directly to path.join() when constructing filesystem paths for flow YAML files. An unauthenticated attacker who can reach the server can read arbitrary .yaml files accessible to the OpenHop process outside the configured flow directory, and can delete arbitrary .yaml files at any path reachable by the process. Because CORS is set to origin: true (allow all origins), a victim's browser can be used to exploit the vulnerability against a loopback-bound instance. Docker deployments bind HOST=0.0.0.0 by default, enabling direct remote exploitation. CVSS Base Score: 8.3 (High). Details FlowStore.filePath() in packages/server/src/store.ts:52–53 constructs a filesystem path by concatenating the caller-supplied id directly into path.join: This result is consumed by two sinks: - Read (packages/server/src/store.ts:78): readFile(this.filePath(id), 'utf-8') - Delete…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-g72f-jw3w-mgh7
- Revision 2 · amended ·
Amended from osv record GHSA-g72f-jw3w-mgh7
- Revision 1 · created ·
Published from ghsa record GHSA-g72f-jw3w-mgh7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59179 Advisory: @openhop/server: Path Traversal in Flow ID File Operations IDs: CVE-2026-59179, GHSA-g72f-jw3w-mgh7 Record: https://patchnext.com/advisories/cve-2026-59179 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @openhop/server 0.3.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @openhop/server: affected <= 0.3.5; fixed in 0.3.6 ## Suggested inspection (read-only) - `npm ls @openhop/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @openhop/server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g72f-jw3w-mgh7 (GitHub-reviewed advisory GHSA-g72f-jw3w-mgh7 lists affected ranges: npm @openhop/server >=0 <=0.3.5) - Verified: https://osv.dev/vulnerability/GHSA-g72f-jw3w-mgh7 (OSV record GHSA-g72f-jw3w-mgh7 lists affected ranges: npm @openhop/server >=0 <0.3.6 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…