Skip to content

← Actionable
Critical, CVSS 9.8amended

ESPHome Device Builder: Renamed auth env vars silently disable dashboard authentication on upgrade

CVE-2026-59178GHSA-rrxg-g2pf-6hh4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (esphome-device-builder 1.0.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-59178: 0.78% estimated exploitation activity in the next 30 days; percentile 55.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The dashboard reads its authentication credentials from $ESPHOMEUSERNAME and $ESPHOMEPASSWORD. Earlier versions, and the legacy esphome dashboard, read the bare $USERNAME and $PASSWORD instead. When the env vars were renamed the bare names were dropped with no fallback, so an operator who had protected their dashboard with USERNAME / PASSWORD (as the older getting started guide documented) loses authentication on upgrade and the dashboard starts open to anyone who can reach its port. Details Credentials are resolved in DashboardSettings.parseargs. The fallback originally read os.getenv("USERNAME") and os.getenv("PASSWORD"). The env var rename (#265) replaced those with ESPHOMEUSERNAME / ESPHOMEPASSWORD and intentionally removed the bare names, because $USERNAME collides with the OS login user on Linux and Windows and reading it on its own would silently promote the shell user to the dashboard username. The rename closed that footgun but introduced a backward compatibility…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rrxg-g2pf-6hh4

  2. Revision 2 · amended ·

    Amended from osv record GHSA-rrxg-g2pf-6hh4

  3. Revision 1 · created ·

    Published from ghsa record GHSA-rrxg-g2pf-6hh4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59178

Advisory: ESPHome Device Builder: Renamed auth env vars silently disable dashboard authentication on upgrade
IDs: CVE-2026-59178, GHSA-rrxg-g2pf-6hh4
Record: https://patchnext.com/advisories/cve-2026-59178 (revision 3, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: esphome-device-builder 1.0.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI esphome-device-builder: affected < 1.0.12; fixed in 1.0.12

## Suggested inspection (read-only)
- `python -m pip show esphome-device-builder`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on esphome-device-builder.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rrxg-g2pf-6hh4 (GitHub-reviewed advisory GHSA-rrxg-g2pf-6hh4 lists affected ranges: PyPI esphome-device-builder >=0 <1.0.12)
- Verified: https://osv.dev/vulnerability/GHSA-rrxg-g2pf-6hh4 (OSV record GHSA-rrxg-g2pf-6hh4 lists affected ranges: PyPI esphome-device-builder >=0 <1.0.12 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…