Skip to content

← Actionable
High, CVSS 7.8amended

functype-mcp-server: MCP set_functype_version Package Alias RCE via Unsanitized pnpm install + Dynamic Import

CVE-2026-59176GHSA-wcjj-9m6g-2fr2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (functype-mcp-server 1.4.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-59176: 0.21% estimated exploitation activity in the next 30 days; percentile 11.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

MCP `set_functype_version` Package Alias RCE via Unsanitized pnpm install + Dynamic Import

Summary The `set_functype_version` MCP tool in `functype-mcp-server` accepts an unconstrained `version` string, interpolates it directly into an npm package specifier (`functype@ `), and installs it via `pnpm add` without any validation. Because npm/pnpm package specifiers support `file:`, `npm:`, and other alias syntaxes, an attacker who can send an MCP `tools/call` request to this tool can cause the server to install an arbitrary local or remote package as `functype`. Immediately after installation, the server calls `initDocsData(true)`, which dynamically imports `functype/cli` from the newly installed location, executing attacker-controlled JavaScript in the MCP server process. This results in full Remote Code Execution (RCE) with the privileges of the server process — full confidentiality, integrity, and availability impact (CVSS 7.8 High).

Details The vulnerable code is in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-wcjj-9m6g-2fr2

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-wcjj-9m6g-2fr2

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-wcjj-9m6g-2fr2

  4. Revision 2 · amended ·

    Amended from osv record GHSA-wcjj-9m6g-2fr2

  5. Revision 1 · created ·

    Published from ghsa record GHSA-wcjj-9m6g-2fr2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59176

Advisory: functype-mcp-server: MCP `set_functype_version` Package Alias RCE via Unsanitized pnpm install + Dynamic Import
IDs: CVE-2026-59176, GHSA-wcjj-9m6g-2fr2
Record: https://patchnext.com/advisories/cve-2026-59176 (revision 5, source checked 3 Nov 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: functype-mcp-server 1.4.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm functype-mcp-server: affected < 1.4.4; fixed in 1.4.4

## Suggested inspection (read-only)
- `npm ls functype-mcp-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on functype-mcp-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wcjj-9m6g-2fr2 (GitHub-reviewed advisory GHSA-wcjj-9m6g-2fr2 lists affected ranges: npm functype-mcp-server >=0 <=1.4.3)
- Verified: https://osv.dev/vulnerability/GHSA-wcjj-9m6g-2fr2 (OSV record GHSA-wcjj-9m6g-2fr2 lists affected ranges: npm functype-mcp-server >=0 <1.4.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…