Skip to content

← Actionable
High, CVSS 7.8amended

Joker linter executed project-local .jokerd/linter.* files during linting

CVE-2026-59172GHSA-m835-3cm9-rggg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/candid82/joker 1.8.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-59172: 0.16% estimated exploitation activity in the next 30 days; percentile 5.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In Joker versions before 1.8.2, joker --lint <file located a .jokerd/ directory by walking up from the linted file and executed matching linter. files from that directory before linting. Because these files are executable Joker/Clojure code, linting a file inside an untrusted repository could execute code supplied by that repository. This could be triggered by editor integrations or CI jobs that automatically run joker --lint on checked-out source code. Patches Fixed in Joker v1.8.2. Executable linter customization files are now loaded only from the user's home .jokerd directory (~/.jokerd/linter.cljc, ~/.jokerd/linter.clj, ~/.jokerd/linter.cljs, or ~/.jokerd/linter.joke). Project-local .jokerd/linter. files are no longer executed. Workarounds Users who cannot upgrade should avoid running joker --lint on untrusted repositories, especially through editor integrations or unattended CI. Removing or disabling project-local .jokerd/linter. files before linting also avoids the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-m835-3cm9-rggg

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6450

  3. Revision 1 · created ·

    Published from osv record GHSA-m835-3cm9-rggg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59172

Advisory: Joker linter executed project-local .jokerd/linter.* files during linting
IDs: CVE-2026-59172, GHSA-m835-3cm9-rggg
Record: https://patchnext.com/advisories/cve-2026-59172 (revision 3, source checked 26 Oct 2026, 15:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/candid82/joker 1.8.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/candid82/joker: affected < 1.8.2; fixed in 1.8.2

## Suggested inspection (read-only)
- Go github.com/candid82/joker: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/candid82/joker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m835-3cm9-rggg (OSV record GHSA-m835-3cm9-rggg lists affected ranges: Go github.com/candid82/joker >=0 <1.8.2 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6450 (OSV record GO-2026-6450 lists affected ranges: Go github.com/candid82/joker >=0 <1.8.2 (fixed))
- Verified: https://github.com/advisories/GHSA-m835-3cm9-rggg (GitHub-reviewed advisory GHSA-m835-3cm9-rggg lists affected ranges: Go github.com/candid82/joker >=0 <1.8.2)

Commands are suggestions: review each one before running it.

Loading voting…