Skip to content

← Actionable
Critical, CVSS 10.0amended

SunEditor: Critical XSS vulnerability - sanitizer bypass

CVE-2026-59167GHSA-6rf4-v2fh-m6p4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (suneditor 2.47.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm suneditor

    Affected
    <= 2.47.10
    Fixed in
    2.47.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-59167: 0.50% estimated exploitation activity in the next 30 days; percentile 42.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary SUNEDITOR v2.47.10 appears to allow JavaScript execution through crafted namespaced HTML elements. The sanitization logic does not fully remove executable event-handler attributes from certain custom/namespaced tags. As a result, an attacker may be able to inject HTML content that executes JavaScript when the rendered element is interacted with. This behavior was observed after the changes introduced in this commit: https://github.com/JiHong88/suneditor/commit/9ed405fb0de676e56cd0e6a13c19c103ad5948d3 --- Affected Version Confirmed vulnerable: SUNEDITOR =< 2.47.10 Potentially affected: Previous versions, if the same sanitization logic is still present --- Proof of Concept The following payload preserves an executable event handler: Simplified PoC: --- Steps to Reproduce 1. Open SUNEDITOR using version 2.47.10. 2. Insert the payload above into the editor. 3. Save or render the generated content. 4. Click the generated element. 5. Observe that JavaScript is executed. --- Impact…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6rf4-v2fh-m6p4

  2. Revision 2 · amended ·

    Amended from osv record GHSA-6rf4-v2fh-m6p4

  3. Revision 1 · created ·

    Published from ghsa record GHSA-6rf4-v2fh-m6p4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59167

Advisory: SunEditor: Critical XSS vulnerability - sanitizer bypass
IDs: CVE-2026-59167, GHSA-6rf4-v2fh-m6p4
Record: https://patchnext.com/advisories/cve-2026-59167 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: suneditor 2.47.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm suneditor: affected <= 2.47.10; fixed in 2.47.11

## Suggested inspection (read-only)
- `npm ls suneditor --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on suneditor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6rf4-v2fh-m6p4 (GitHub-reviewed advisory GHSA-6rf4-v2fh-m6p4 lists affected ranges: npm suneditor >=0 <=2.47.10)
- Verified: https://osv.dev/vulnerability/GHSA-6rf4-v2fh-m6p4 (OSV record GHSA-6rf4-v2fh-m6p4 lists affected ranges: npm suneditor >=0 <2.47.11 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…