Skip to content

← Actionable
Critical, CVSS 9.1amended

Mnemosyne has JWT signature verification bypass sync server that allows authentication bypass

CVE-2026-59163GHSA-xcw4-53cc-hv32

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mnemosyne-memory 3.10.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-59163: 0.33% estimated exploitation activity in the next 30 days; percentile 25.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Mnemosyne sync server's authentication check decoded JWT bearer tokens but never verified their HMAC-SHA256 signatures. Any well-formed token was accepted, allowing an unauthenticated attacker to impersonate any user and read or modify their sync data. Severity: Critical CVSS 3.1: AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N = 9.1 Assumes the sync server endpoint is network-reachable. If your deployment is localhost-only, the score drops substantially and severity becomes High or Medium depending on local exposure. Confirm your threat model. Affected versions All mnemosyne versions exposing the sync server endpoint, up to and including v3.10.0. Patched versions v3.10.1 (commit a0b6b871 on branch security/jwt-signature-verification) Description The sync server uses JWT bearer tokens to authenticate clients. Prior to v3.10.1, the auth check in mnemosyne/core/syncserver.py parsed the JWT's header and payload using base64 decoding, then passed the token to a jwt library call with…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xcw4-53cc-hv32

  2. Revision 2 · amended ·

    Amended from osv record GHSA-xcw4-53cc-hv32

  3. Revision 1 · created ·

    Published from ghsa record GHSA-xcw4-53cc-hv32

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59163

Advisory: Mnemosyne has JWT signature verification bypass sync server that allows authentication bypass
IDs: CVE-2026-59163, GHSA-xcw4-53cc-hv32
Record: https://patchnext.com/advisories/cve-2026-59163 (revision 3, source checked 26 Oct 2026, 13:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mnemosyne-memory 3.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mnemosyne-memory: affected <= 3.10.0; fixed in 3.10.1

## Suggested inspection (read-only)
- `python -m pip show mnemosyne-memory`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mnemosyne-memory.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xcw4-53cc-hv32 (GitHub-reviewed advisory GHSA-xcw4-53cc-hv32 lists affected ranges: PyPI mnemosyne-memory >=0 <=3.10.0)
- Verified: https://osv.dev/vulnerability/GHSA-xcw4-53cc-hv32 (OSV record GHSA-xcw4-53cc-hv32 lists affected ranges: PyPI mnemosyne-memory >=0 <3.10.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…