Skip to content

← Actionable
High, CVSS 8.8amended

@yeger/turbo-graph: Unauthenticated Network-Exposed Task Execution via /api/run

CVE-2026-59160GHSA-2r5q-h53f-9rp3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@yeger/turbo-graph 2.8.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-59160: 0.49% estimated exploitation activity in the next 30 days; percentile 41.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Unauthenticated Network-Exposed Turborepo Task Execution via /api/run Summary @yeger/turbo-graph starts its embedded Next.js server without binding to the loopback interface, causing it to listen on all network interfaces (0.0.0.0:29312 by default). The /api/run HTTP endpoint exposed by this server performs no authentication, authorization, CSRF protection, or task allowlist check before executing attacker-supplied Turborepo task names via spawn(). Any adjacent-network attacker can send an unauthenticated GET request to trigger arbitrary tasks defined in the victim's repository, resulting in code execution, file modification, destructive build side effects, or deployment of attacker-chosen targets with the privileges of the developer's OS user. Details Two independent flaws combine to create a remotely exploitable unauthenticated code execution vulnerability: Flaw 1 — Server bound to all interfaces (not loopback) packages/turbo-graph/src/index.ts:44 calls .listen(options.port,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2r5q-h53f-9rp3

  2. Revision 2 · amended ·

    Amended from osv record GHSA-2r5q-h53f-9rp3

  3. Revision 1 · created ·

    Published from ghsa record GHSA-2r5q-h53f-9rp3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59160

Advisory: @yeger/turbo-graph: Unauthenticated Network-Exposed Task Execution via /api/run
IDs: CVE-2026-59160, GHSA-2r5q-h53f-9rp3
Record: https://patchnext.com/advisories/cve-2026-59160 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @yeger/turbo-graph 2.8.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @yeger/turbo-graph: affected <= 2.8.8; fixed in 2.8.12

## Suggested inspection (read-only)
- `npm ls @yeger/turbo-graph --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @yeger/turbo-graph.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2r5q-h53f-9rp3 (GitHub-reviewed advisory GHSA-2r5q-h53f-9rp3 lists affected ranges: npm @yeger/turbo-graph >=0 <=2.8.8)
- Verified: https://osv.dev/vulnerability/GHSA-2r5q-h53f-9rp3 (OSV record GHSA-2r5q-h53f-9rp3 lists affected ranges: npm @yeger/turbo-graph >=0 <2.8.12 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…