Skip to content

← Actionable
Medium, CVSS 6.5amended

webhookd: Unrestricted HTTP Header to Shell Variable Injection

CVE-2026-59157GHSA-v25g-mvwr-f5fp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ncarlier/webhookd 1.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-59157: 0.60% estimated exploitation activity in the next 30 days; percentile 48.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Before 1.22, if the Basic Auth (htpasswd) middleware was not configured, all incoming HTTP headers were blindly forwarded to the webhook script execution environment as shell variables. While the Basic Auth middleware correctly strips the authentication header (X-WebAuthn-User) from the incoming request before conditionally re-injecting it on successful authentication, disabling Basic Auth left the system vulnerable if deployed behind an unhardened reverse proxy. Impact If an upstream reverse proxy is not properly hardened to strip client-provided authentication headers, an attacker could manually supply these headers (e.g., X-WebAuthn-User). A webhook script relying on this forwarded header for privilege elevation or identity verification could therefore be exploited to bypass security controls and impersonate other users. Mitigation The WHDALLOWEDUPSTREAMHEADERS configuration setting has been introduced to enforce a strict allowlist of HTTP headers that can be converted…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v25g-mvwr-f5fp

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6451

  3. Revision 1 · created ·

    Published from osv record GHSA-v25g-mvwr-f5fp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-59157

Advisory: webhookd: Unrestricted HTTP Header to Shell Variable Injection
IDs: CVE-2026-59157, GHSA-v25g-mvwr-f5fp
Record: https://patchnext.com/advisories/cve-2026-59157 (revision 3, source checked 26 Oct 2026, 15:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/ncarlier/webhookd 1.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/ncarlier/webhookd: affected < 1.22.0; fixed in 1.22.0

## Suggested inspection (read-only)
- Go github.com/ncarlier/webhookd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/ncarlier/webhookd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v25g-mvwr-f5fp (OSV record GHSA-v25g-mvwr-f5fp lists affected ranges: Go github.com/ncarlier/webhookd >=0 <1.22.0 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6451 (OSV record GO-2026-6451 lists affected ranges: Go github.com/ncarlier/webhookd >=0 <1.22.0 (fixed))
- Verified: https://github.com/advisories/GHSA-v25g-mvwr-f5fp (GitHub-reviewed advisory GHSA-v25g-mvwr-f5fp lists affected ranges: Go github.com/ncarlier/webhookd >=0 <1.22.0)

Commands are suggestions: review each one before running it.

Loading voting…