LangSmith SDK TracingMiddleware: Arbitrary server-side file read
CVE-2026-59152GHSA-f4xh-w4cj-qxq8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langsmith 0.8.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langsmith
- Affected
- < 0.8.18
- Fixed in
- 0.8.18
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f4xh-w4cj-qxq8 lists affected ranges: PyPI langsmith >=0 <0.8.18 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f4xh-w4cj-qxq8 lists affected ranges: PyPI langsmith >=0 <0.8.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-59152: 0.20% estimated exploitation activity in the next 30 days; percentile 9.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An attacker who can send an HTTP request to a server running the LangSmith SDK's TracingMiddleware can cause that server to read an arbitrary file from its local filesystem and upload the contents to LangSmith as a trace attachment. Depending on how the distributed trace system is deployed, triggering a read may not require authentication. Retrieving the contents requires read access to the LangSmith workspace the traces are sent to. The net effect is a trust-boundary crossing: a party with workspace trace-read access (for example a low-privilege workspace member, a contractor, or a compromised teammate account) gains the ability to read files from any server running TracingMiddleware, a capability outside that workspace's intended trust boundary. Impact Confidentiality (High): arbitrary read of files accessible to the server process, exposed to anyone with workspace trace-read access. Details Two defects combine. A field supplied through a tracing-propagation header was…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-f4xh-w4cj-qxq8
- Revision 1 · created ·
Published from osv record GHSA-f4xh-w4cj-qxq8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59152 Advisory: LangSmith SDK TracingMiddleware: Arbitrary server-side file read IDs: CVE-2026-59152, GHSA-f4xh-w4cj-qxq8 Record: https://patchnext.com/advisories/cve-2026-59152 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langsmith 0.8.18. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langsmith: affected < 0.8.18; fixed in 0.8.18 ## Suggested inspection (read-only) - `python -m pip show langsmith`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langsmith. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f4xh-w4cj-qxq8 (OSV record GHSA-f4xh-w4cj-qxq8 lists affected ranges: PyPI langsmith >=0 <0.8.18 (fixed)) - Verified: https://github.com/advisories/GHSA-f4xh-w4cj-qxq8 (GitHub-reviewed advisory GHSA-f4xh-w4cj-qxq8 lists affected ranges: PyPI langsmith >=0 <0.8.18) Commands are suggestions: review each one before running it.
Loading voting…