Prowler: SAML Domain Claiming Enables Cross-Tenant Account Takeover
CVE-2026-59151GHSA-h8m9-jgf8-vwvp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (prowler-cloud 5.30.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI prowler-cloud
- Affected
- < 5.30.3
- Fixed in
- 5.30.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h8m9-jgf8-vwvp lists affected ranges: PyPI prowler-cloud >=0 <5.30.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h8m9-jgf8-vwvp lists affected ranges: PyPI prowler-cloud >=0 <5.30.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-100169: 0.85% estimated exploitation activity in the next 30 days; percentile 58.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
- CVE-2026-59151: 0.53% estimated exploitation activity in the next 30 days; percentile 45.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
SAML Tenant Binding Enables Cross-Tenant Account Takeover Summary Prowler's SAML authentication flow trusted the email domain asserted in a SAMLResponse when deciding which tenant should receive the final token. A malicious tenant with its own SAML configuration and a self-controlled IdP could complete a valid SAML flow for its own configured domain, while asserting an email address from another configured domain. In the vulnerable flow, the ACS finish logic later derived the tenant from the asserted email domain instead of binding token issuance to the tenant associated with the validated SAML configuration. This could cause a token to be issued for the wrong tenant. The attacker does not generally need to claim the victim's email domain. If the victim tenant already has SAML configured for that domain, another tenant cannot claim it because SAMLConfiguration.emaildomain and SAMLDomainIndex.emaildomain are globally unique. Details The confirmed root cause is in the SAML ACS finish…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h8m9-jgf8-vwvp
- Revision 2 · amended ·
Amended from osv record GHSA-h8m9-jgf8-vwvp
- Revision 1 · created ·
Published from ghsa record GHSA-h8m9-jgf8-vwvp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-59151 Advisory: Prowler: SAML Domain Claiming Enables Cross-Tenant Account Takeover IDs: CVE-2026-59151, GHSA-h8m9-jgf8-vwvp Record: https://patchnext.com/advisories/cve-2026-59151 (revision 3, source checked 26 Oct 2026, 13:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: prowler-cloud 5.30.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI prowler-cloud: affected < 5.30.3; fixed in 5.30.3 ## Suggested inspection (read-only) - `python -m pip show prowler-cloud`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on prowler-cloud. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h8m9-jgf8-vwvp (GitHub-reviewed advisory GHSA-h8m9-jgf8-vwvp lists affected ranges: PyPI prowler-cloud >=0 <5.30.3) - Verified: https://osv.dev/vulnerability/GHSA-h8m9-jgf8-vwvp (OSV record GHSA-h8m9-jgf8-vwvp lists affected ranges: PyPI prowler-cloud >=0 <5.30.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…