Skip to content

← Actionable
Medium, CVSS 4.8amended

Grav: Stored CSS injection via Markdown image resize() bypasses prior media style sanitizers in Grav

CVE-2026-58657GHSA-ffmg-hfvg-jhg9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 2.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getgrav/grav

    Affected
    >= 2.0.0-rc.9, <= 2.0.0-rc.9
    Fixed in
    2.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-58657: 0.27% estimated exploitation activity in the next 30 days; percentile 18.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Grav 2.0.0-rc.9 and the current 2.0 branch still allow stored CSS injection through Markdown image media actions. The prior media hardening rejects direct ?style= payloads and unsafe attribute() fallbacks, but the adjacent resize() action still writes caller-controlled values directly into styleAttributes. A publisher who can edit page Markdown can store a crafted image URL that renders additional CSS declarations in the final <img style=... attribute. This crosses the same lower-privileged publisher to higher-privileged reviewer/admin rendered-content boundary as the earlier media style and attribute advisories. Impact A lower-privileged content editor can persist CSS declarations that are rendered when a higher-privileged user views the page or admin preview. The demonstrated payload creates a full-viewport fixed overlay by injecting position:fixed, viewport dimensions, background color, and z-index declarations. This does not require JavaScript execution. The impact is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-ffmg-hfvg-jhg9

  2. Revision 1 · created ·

    Published from osv record GHSA-ffmg-hfvg-jhg9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-58657

Advisory: Grav: Stored CSS injection via Markdown image resize() bypasses prior media style sanitizers in Grav
IDs: CVE-2026-58657, GHSA-ffmg-hfvg-jhg9
Record: https://patchnext.com/advisories/cve-2026-58657 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 2.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getgrav/grav: affected >= 2.0.0-rc.9, <= 2.0.0-rc.9; fixed in 2.0.0

## Suggested inspection (read-only)
- Packagist getgrav/grav: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getgrav/grav.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ffmg-hfvg-jhg9 (OSV record GHSA-ffmg-hfvg-jhg9 lists affected ranges: Packagist getgrav/grav >=2.0.0-rc.9 <2.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-ffmg-hfvg-jhg9 (GitHub-reviewed advisory GHSA-ffmg-hfvg-jhg9 lists affected ranges: Packagist getgrav/grav >=2.0.0-rc.9 <=2.0.0-rc.9)

Commands are suggestions: review each one before running it.

Loading voting…