appium-mcp: Unescaped Locator Data XSS in MCP-UI Resource (createLocatorGeneratorUI)
CVE-2026-58500GHSA-x975-rgx4-5fh4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (appium-mcp 1.85.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm appium-mcp
- Affected
- <= 1.85.9
- Fixed in
- 1.85.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x975-rgx4-5fh4 lists affected ranges: npm appium-mcp >=0 <1.85.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x975-rgx4-5fh4 lists affected ranges: npm appium-mcp >=0 <=1.85.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N
- EPSS
- CVE-2026-58500: 0.40% estimated exploitation activity in the next 30 days; percentile 34.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Unescaped Locator Data XSS in MCP-UI Resource (createLocatorGeneratorUI) Summary appium-mcp's createLocatorGeneratorUI function interpolates attacker-controlled element attributes — text, content-desc, resource-id, and locator selector values — directly into an HTML template literal without any HTML or JavaScript context escaping. An attacker who controls the UI of the app under test can inject arbitrary HTML and JavaScript into the MCP UI resource returned by the generatelocators tool. When a victim's MCP client renders this resource, the injected script executes and can invoke arbitrary MCP tools via window.parent.postMessage, leading to unauthorized MCP tool execution such as taking screenshots, reading page source, or any other registered capability. Details The vulnerability is a stored/reflected cross-site scripting (XSS) issue in the MCP UI generation pipeline. Vulnerable sink — src/ui/mcp-ui-utils.ts:730–740: None of element.text, element.contentDesc, element.resourceId,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x975-rgx4-5fh4
- Revision 1 · created ·
Published from osv record GHSA-x975-rgx4-5fh4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-58500 Advisory: appium-mcp: Unescaped Locator Data XSS in MCP-UI Resource (createLocatorGeneratorUI) IDs: CVE-2026-58500, GHSA-x975-rgx4-5fh4 Record: https://patchnext.com/advisories/cve-2026-58500 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: appium-mcp 1.85.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm appium-mcp: affected <= 1.85.9; fixed in 1.85.10 ## Suggested inspection (read-only) - `npm ls appium-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on appium-mcp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x975-rgx4-5fh4 (OSV record GHSA-x975-rgx4-5fh4 lists affected ranges: npm appium-mcp >=0 <1.85.10 (fixed)) - Verified: https://github.com/advisories/GHSA-x975-rgx4-5fh4 (GitHub-reviewed advisory GHSA-x975-rgx4-5fh4 lists affected ranges: npm appium-mcp >=0 <=1.85.9) Commands are suggestions: review each one before running it.
Loading voting…