Skip to content

← Actionable
High, CVSS 8.6amended

Uni-CLI: Legacy HTTP MCP transport accepted browser-originated localhost requests

CVE-2026-58497GHSA-v3f4-w7r7-v3hm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@zenalexa/unicli 0.225.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-58497: 0.26% estimated exploitation activity in the next 30 days; percentile 17.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Uni-CLI versions before 0.225.2 exposed the legacy JSON-RPC-over-HTTP MCP transport on loopback without validating browser Origin headers before routing requests. A malicious web page could send a CORS simple POST request, such as text/plain, to the local /mcp endpoint and deliver a JSON-RPC body to the dispatcher. If the user had started the local MCP HTTP transport, that page could drive tools/call requests against the user's local Uni-CLI server. The Streamable HTTP transport already enforced this browser-to-localhost boundary. The legacy stateless HTTP path did not, so the two HTTP transports had drifted. This issue is about the browser-to-localhost boundary; it does not change Uni-CLI's local-code-execution trust model. Patches Version 0.225.2 fixes the issue by moving the Origin policy into a shared guard and applying it before routing in both HTTP transports. Non-loopback browser Origins are rejected with HTTP 403 before health, OAuth, or /mcp dispatch runs. Non-browser…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v3f4-w7r7-v3hm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-v3f4-w7r7-v3hm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-58497

Advisory: Uni-CLI: Legacy HTTP MCP transport accepted browser-originated localhost requests
IDs: CVE-2026-58497, GHSA-v3f4-w7r7-v3hm
Record: https://patchnext.com/advisories/cve-2026-58497 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @zenalexa/unicli 0.225.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @zenalexa/unicli: affected < 0.225.2; fixed in 0.225.2

## Suggested inspection (read-only)
- `npm ls @zenalexa/unicli --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @zenalexa/unicli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v3f4-w7r7-v3hm (OSV record GHSA-v3f4-w7r7-v3hm lists affected ranges: npm @zenalexa/unicli >=0 <0.225.2 (fixed))
- Verified: https://github.com/advisories/GHSA-v3f4-w7r7-v3hm (GitHub-reviewed advisory GHSA-v3f4-w7r7-v3hm lists affected ranges: npm @zenalexa/unicli >=0 <0.225.2)

Commands are suggestions: review each one before running it.

Loading voting…