Skip to content

← Actionable
High, CVSS 7.1amended

Network-AI: Poisoned environment backup manifest allows arbitrary recursive deletion during backup pruning

CVE-2026-58484GHSA-2fmp-9rvw-hc96

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (network-ai 5.12.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-58484: 0.20% estimated exploitation activity in the next 30 days; percentile 10.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary EnvironmentManager.listBackups() reads each backup's manifest.json and trusts the manifest's path field. EnvironmentManager.pruneBackups() later passes that trusted entry.path directly to rmSync(entry.path, { recursive: true, force: true }). An attacker who can place or modify a manifest inside data/<env/.backups/<name/manifest.json can cause network-ai env backup prune --env <env --keep <n or any code path invoking pruneBackups() to recursively delete an arbitrary path accessible to the Network-AI process user. Confirmed in Network-AI 5.12.1. Details listBackups() trusts manifest content from disk: pruneBackups() uses the attacker-controlled entry.path as the deletion target: Default CLI reachability exists through network-ai env backup prune --env <env --keep <n. Affected source evidence: - lib/env-manager.ts:505-523 — reads trusted backup entries from manifest.json. - lib/env-manager.ts:529-541 — recursively deletes entry.path. - bin/cli.ts:464-472 — default CLI exposes…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2fmp-9rvw-hc96

  2. Revision 1 · created ·

    Published from osv record GHSA-2fmp-9rvw-hc96

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-58484

Advisory: Network-AI: Poisoned environment backup manifest allows arbitrary recursive deletion during backup pruning
IDs: CVE-2026-58484, GHSA-2fmp-9rvw-hc96
Record: https://patchnext.com/advisories/cve-2026-58484 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: network-ai 5.12.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm network-ai: affected <= 5.12.1; fixed in 5.12.2

## Suggested inspection (read-only)
- `npm ls network-ai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on network-ai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2fmp-9rvw-hc96 (OSV record GHSA-2fmp-9rvw-hc96 lists affected ranges: npm network-ai >=0 <5.12.2 (fixed))
- Verified: https://github.com/advisories/GHSA-2fmp-9rvw-hc96 (GitHub-reviewed advisory GHSA-2fmp-9rvw-hc96 lists affected ranges: npm network-ai >=0 <=5.12.1)

Commands are suggestions: review each one before running it.

Loading voting…