Skip to content

← Actionable
Medium, CVSS 5.9amended

Network-AI: ApprovalInbox HTTP server has no authentication — anyone can approve pending agent actions

CVE-2026-58482GHSA-mxjx-28vx-xjjj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (network-ai 5.12.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm network-ai

    Affected
    >= 5.0.0, <= 5.12.1
    Fixed in
    5.12.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:H/A:N
EPSS
  • CVE-2026-58482: 0.20% estimated exploitation activity in the next 30 days; percentile 9.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary network-ai's ApprovalInbox (lib/approval-inbox.ts) is a shipped, exported, documented feature — "a web-accessible approval queue with REST API … and SSE streaming" (SECURITY.md). It is the network surface of the human-in-the-loop Approval Gate, which ApprovalGate uses to require explicit human approval for "high-risk operations (writes, shell commands, budget spend)" (SECURITY.md). The HTTP server it exposes has no authentication of any kind and sets Access-Control-Allow-Origin: on every route, including the state-changing POST /approvals/:id/approve and /deny. As a result, any party who can send an HTTP request to the inbox port — a co-located process, a container/SSRF on the same host, a remote client when the operator binds a non-loopback address, or any website the operator visits in a browser (via the wildcard CORS) — can enumerate pending approvals and approve them, defeating the entire human-in-the-loop control and causing the gated high-risk action (e.g. a shell…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mxjx-28vx-xjjj

  2. Revision 1 · created ·

    Published from osv record GHSA-mxjx-28vx-xjjj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-58482

Advisory: Network-AI: ApprovalInbox HTTP server has no authentication — anyone can approve pending agent actions
IDs: CVE-2026-58482, GHSA-mxjx-28vx-xjjj
Record: https://patchnext.com/advisories/cve-2026-58482 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: network-ai 5.12.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm network-ai: affected >= 5.0.0, <= 5.12.1; fixed in 5.12.2

## Suggested inspection (read-only)
- `npm ls network-ai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on network-ai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mxjx-28vx-xjjj (OSV record GHSA-mxjx-28vx-xjjj lists affected ranges: npm network-ai >=5.0.0 <5.12.2 (fixed))
- Verified: https://github.com/advisories/GHSA-mxjx-28vx-xjjj (GitHub-reviewed advisory GHSA-mxjx-28vx-xjjj lists affected ranges: npm network-ai >=5.0.0 <=5.12.1)

Commands are suggestions: review each one before running it.

Loading voting…