Skip to content

← Actionable
Critical, CVSS 9.3amended

Cognee allows non-superusers to overwrite global LLM configuration

CVE-2026-58473GHSA-49f7-whx5-4256

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cognee 1.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI cognee

    Affected
    < 1.5.0
    Fixed in
    1.5.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-58473: 0.51% estimated exploitation activity in the next 30 days; percentile 43.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cognee before 1.2.0 contains an improper access control vulnerability that allows unauthenticated attackers to overwrite the global LLM provider configuration by self-registering an account and calling the settings endpoint, which performs no admin or superuser check. Attackers can redirect all LLM operations instance-wide to an attacker-controlled endpoint by exploiting the process-wide singleton configuration cache, enabling exfiltration of prompts, uploaded documents, extracted entities, and knowledge graph content from all users.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-49f7-whx5-4256

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-49f7-whx5-4256

  4. Revision 1 · created ·

    Published from ghsa record GHSA-49f7-whx5-4256

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-58473

Advisory: Cognee allows non-superusers to overwrite global LLM configuration
IDs: CVE-2026-58473, GHSA-49f7-whx5-4256
Record: https://patchnext.com/advisories/cve-2026-58473 (revision 4, source checked 26 Oct 2026, 13:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cognee 1.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI cognee: affected < 1.5.0; fixed in 1.5.0

## Suggested inspection (read-only)
- `python -m pip show cognee`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cognee.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-49f7-whx5-4256 (GitHub-reviewed advisory GHSA-49f7-whx5-4256 lists affected ranges: PyPI cognee >=0 <1.5.0)
- Verified: https://osv.dev/vulnerability/GHSA-49f7-whx5-4256 (OSV record GHSA-49f7-whx5-4256 lists affected ranges: PyPI cognee >=0 <1.5.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…