Skip to content

← Actionable
Low, CVSS 2.7

Gitea: Cross-repository label-ID enumeration oracle via unscoped DeleteIssueLabel API

CVE-2026-58445GHSA-pgqf-926r-548m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (code.gitea.io/gitea 1.27.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-58445: 0.37% estimated exploitation activity in the next 30 days; percentile 30.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The API endpoint DELETE /repos/{owner}/{repo}/issues/{index}/labels/{id} loads the label by ID with a global, unscoped lookup and never verifies the label belongs to the URL's repository (or its owning organization). Because the response status differs by whether the label ID exists anywhere on the instance (204) versus not (422), an authenticated user can use the endpoint as a cross-repository label-ID existence / enumeration oracle, including for labels in repositories and organizations they cannot access. Severity - The leaked information is minimal (existence/count of label IDs instance-wide); no label name, color, or owning repository is disclosed, and no cross-repository write occurs. Affected / patched versions - Affected: through 1.26.3 (latest at time of report). - Patched: none yet. Details DeleteIssueLabel resolves the label with a global loader and never checks its scope: GetLabelByID (models/issues/label.go) is e.ID(labelID).Get(l) with no repoid / orgid filter.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pgqf-926r-548m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-58445

Advisory: Gitea: Cross-repository label-ID enumeration oracle via unscoped DeleteIssueLabel API
IDs: CVE-2026-58445, GHSA-pgqf-926r-548m
Record: https://patchnext.com/advisories/cve-2026-58445 (revision 1, source checked 26 Oct 2026, 15:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: code.gitea.io/gitea 1.27.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go code.gitea.io/gitea: affected < 1.27.0; fixed in 1.27.0

## Suggested inspection (read-only)
- Go code.gitea.io/gitea: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on code.gitea.io/gitea.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pgqf-926r-548m (GitHub-reviewed advisory GHSA-pgqf-926r-548m lists affected ranges: Go code.gitea.io/gitea >=0 <1.27.0)

Commands are suggestions: review each one before running it.

Loading voting…