Network-AI: EnvironmentManager.restore() backup ID path traversal copies arbitrary directories into environment data
CVE-2026-58413GHSA-48x2-6pr9-2jjf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (network-ai 5.12.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm network-ai
- Affected
- <= 5.12.1
- Fixed in
- 5.12.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-48x2-6pr9-2jjf lists affected ranges: npm network-ai >=0 <5.12.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-48x2-6pr9-2jjf lists affected ranges: npm network-ai >=0 <=5.12.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-58413: 0.19% estimated exploitation activity in the next 30 days; percentile 8.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary EnvironmentManager.restore(env, backupId) computes the backup path with join(envDir, '.backups', backupId) and only checks that this path exists. It does not resolve the result or verify that it remains under data/<env/.backups. A caller can pass a traversal backup ID such as ../../../outside/source-dir to restore files from an arbitrary directory into the target environment data directory. Confirmed in Network-AI 5.12.1. Details restore() builds backupPath directly from caller-controlled backupId: There is no resolved containment check that ensures backupPath remains under backupsDir. Default CLI reachability exists through network-ai env backup restore --env <env --backup <id. Affected source evidence: - lib/env-manager.ts:474-499 — vulnerable restore path construction and copy. - bin/cli.ts:441-458 — default CLI exposes restore with caller-controlled --backup. PoC This PoC uses only temporary directories and restores trustlevels.json from an external directory into…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-48x2-6pr9-2jjf
- Revision 1 · created ·
Published from osv record GHSA-48x2-6pr9-2jjf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-58413 Advisory: Network-AI: EnvironmentManager.restore() backup ID path traversal copies arbitrary directories into environment data IDs: CVE-2026-58413, GHSA-48x2-6pr9-2jjf Record: https://patchnext.com/advisories/cve-2026-58413 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: network-ai 5.12.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm network-ai: affected <= 5.12.1; fixed in 5.12.2 ## Suggested inspection (read-only) - `npm ls network-ai --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on network-ai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-48x2-6pr9-2jjf (OSV record GHSA-48x2-6pr9-2jjf lists affected ranges: npm network-ai >=0 <5.12.2 (fixed)) - Verified: https://github.com/advisories/GHSA-48x2-6pr9-2jjf (GitHub-reviewed advisory GHSA-48x2-6pr9-2jjf lists affected ranges: npm network-ai >=0 <=5.12.1) Commands are suggestions: review each one before running it.
Loading voting…