Skip to content

← Actionable
Medium, CVSS 5.3amended

Sync-in Server has Username/Login Enumeration via Timing Side-Channel on POST /api/auth/login (incomplete fix of the prior timing-attack advisory)

CVE-2026-58272GHSA-29hq-23m2-2j47

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sync-in/server 2.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-58272: 0.39% estimated exploitation activity in the next 30 days; percentile 33.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary validateUser() in backend/src/authentication/providers/mysql/auth-provider-mysql.service.ts returns immediately when the supplied login/email does not match any account, without ever calling comparePassword(): async validateUser(loginOrEmail: string, password: string, ip?: string, scope?: AUTHSCOPE): Promise<UserModel { let user: UserModel try { user = await this.usersManager.findUser(loginOrEmail, false) } catch (e) { ... } if (!user) { this.logger.warn(...) return null // <-- comparePassword() is never reached here } return await this.usersManager.logUser(user, password, ip, scope) } comparePassword() (backend/src/common/functions.ts) already contains a dummy-hash branch that was clearly added to defend against exactly this class of attack: export async function comparePassword(password: string, hash?: string | null): Promise<boolean { if (!hash) { // No hash, waste time for time-based attacks await bcrypt.compare(password, DUMMYPASSWORDHASH) return false } return await…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-29hq-23m2-2j47

  2. Revision 2 · amended ·

    Amended from osv record GHSA-29hq-23m2-2j47

  3. Revision 1 · created ·

    Published from ghsa record GHSA-29hq-23m2-2j47

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-58272

Advisory: Sync-in Server has Username/Login Enumeration via Timing Side-Channel on POST /api/auth/login (incomplete fix of the prior timing-attack advisory)
IDs: CVE-2026-58272, GHSA-29hq-23m2-2j47
Record: https://patchnext.com/advisories/cve-2026-58272 (revision 3, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @sync-in/server 2.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @sync-in/server: affected <= 2.4.0; fixed in 2.4.1

## Suggested inspection (read-only)
- `npm ls @sync-in/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @sync-in/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-29hq-23m2-2j47 (GitHub-reviewed advisory GHSA-29hq-23m2-2j47 lists affected ranges: npm @sync-in/server >=0 <=2.4.0)
- Verified: https://osv.dev/vulnerability/GHSA-29hq-23m2-2j47 (OSV record GHSA-29hq-23m2-2j47 lists affected ranges: npm @sync-in/server >=0 <2.4.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…