@sync-in/server vulnerable to TOTP Brute-Force via POST /api/app/sync/register
CVE-2026-58271GHSA-274f-6w77-8qm9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sync-in/server 2.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @sync-in/server
- Affected
- <= 2.3.0
- Fixed in
- 2.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-274f-6w77-8qm9 lists affected ranges: npm @sync-in/server >=0 <=2.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-274f-6w77-8qm9 lists affected ranges: npm @sync-in/server >=0 <2.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-58271: 0.22% estimated exploitation activity in the next 30 days; percentile 12.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected component: Sync-in Server v2.3.0, POST /api/app/sync/register. Required attacker capability: Valid login and password for a TOTP-enabled account with desktop sync permission. Summary POST /api/app/sync/register accepts credentials and a TOTP code to register a desktop sync client. In the vulnerable version, on a failed TOTP attempt, SyncClientsManager.register() called updateAccesses(user, ip, false), which hit a freeze branch that wrote passwordAttempts back unchanged. The counter never reached USERMAXPASSWORDATTEMPTS (10), so the account lockout gate never fired for repeated TOTP failures through this endpoint. A successful TOTP guess registers a sync client and returns a {clientId, clientToken} pair, provided the account has the required desktop app permission and the registration payload is valid. The token can then be exchanged via POST /api/app/sync/auth/cookie for an authenticated session. While the guessed TOTP code is still valid, and because the attacker already…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-274f-6w77-8qm9
- Revision 2 · amended ·
Amended from osv record GHSA-274f-6w77-8qm9
- Revision 1 · created ·
Published from ghsa record GHSA-274f-6w77-8qm9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-58271 Advisory: @sync-in/server vulnerable to TOTP Brute-Force via `POST /api/app/sync/register` IDs: CVE-2026-58271, GHSA-274f-6w77-8qm9 Record: https://patchnext.com/advisories/cve-2026-58271 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @sync-in/server 2.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @sync-in/server: affected <= 2.3.0; fixed in 2.4.0 ## Suggested inspection (read-only) - `npm ls @sync-in/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @sync-in/server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-274f-6w77-8qm9 (GitHub-reviewed advisory GHSA-274f-6w77-8qm9 lists affected ranges: npm @sync-in/server >=0 <=2.3.0) - Verified: https://osv.dev/vulnerability/GHSA-274f-6w77-8qm9 (OSV record GHSA-274f-6w77-8qm9 lists affected ranges: npm @sync-in/server >=0 <2.4.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…