Skip to content

← Actionable
Medium, CVSS 6.5amended

Anki: User scripts in iframes have access to the internal Anki API

CVE-2026-58266GHSA-cw6h-ffmh-x6vh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aqt 25.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI aqt

    Affected
    <= 25.9.3
    Fixed in
    25.9.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-58266: 0.22% estimated exploitation activity in the next 30 days; percentile 12.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Anki's webview-based pages communicate with the Rust backend using an internal localhost API. Anki implements measures to prevent user scripts run in the reviewer/editor from accessing this API (https://github.com/ankitects/anki/pull/3925) but it inadvertently allows access to scripts included via iframes in the editor. While overall only a limited set of API methods are exposed, some such as getImageForOcclusion can read arbitrary files. CWE: CWE-22 (Path Traversal) Reporter: Bankde (Eakasit) Affected Products | Ecosystem | Package | Affected Versions | | --------- | ------- | ----------------- | | PyPI | aqt | <= 25.09.3 | Impact Any desktop Anki user (Windows, macOS, Linux) who imports an untrusted .apkg and views card with an embedded iframe is vulnerable. No special configuration is required. The attacker can read any file accessible to the Anki process and exfiltrate its contents over the network. Patches A patch is available in 25.09.4 Workarounds - Do not import .apkg…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cw6h-ffmh-x6vh

  2. Revision 1 · created ·

    Published from osv record GHSA-cw6h-ffmh-x6vh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-58266

Advisory: Anki: User scripts in iframes have access to the internal Anki API
IDs: CVE-2026-58266, GHSA-cw6h-ffmh-x6vh
Record: https://patchnext.com/advisories/cve-2026-58266 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aqt 25.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI aqt: affected <= 25.9.3; fixed in 25.9.4

## Suggested inspection (read-only)
- `python -m pip show aqt`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aqt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cw6h-ffmh-x6vh (OSV record GHSA-cw6h-ffmh-x6vh lists affected ranges: PyPI aqt >=0 <25.9.4 (fixed))
- Verified: https://github.com/advisories/GHSA-cw6h-ffmh-x6vh (GitHub-reviewed advisory GHSA-cw6h-ffmh-x6vh lists affected ranges: PyPI aqt >=0 <=25.9.3)

Commands are suggestions: review each one before running it.

Loading voting…