Skip to content

← Actionable
High, CVSS 7.0

SAP Approuter has an Information Disclosure vulnerability

CVE-2026-58230GHSA-vhh6-v828-x62f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sap/approuter 23.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:L
EPSS
  • CVE-2026-58230: 0.31% estimated exploitation activity in the next 30 days; percentile 24.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

SAP Approuter does not sufficiently validate certain token content under specific configurations. An unauthenticated attacker could send a specially crafted token to cause sensitive credential material to be sent to an attacker-controlled destination. The attack complexity is high due to non-default preconditions required in the target environment. This results in a high impact on confidentiality and a low impact on integrity and availability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vhh6-v828-x62f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-58230

Advisory: SAP Approuter has an Information Disclosure vulnerability
IDs: CVE-2026-58230, GHSA-vhh6-v828-x62f
Record: https://patchnext.com/advisories/cve-2026-58230 (revision 1, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @sap/approuter 23.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @sap/approuter: affected < 23.0.0; fixed in 23.0.0

## Suggested inspection (read-only)
- `npm ls @sap/approuter --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @sap/approuter.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vhh6-v828-x62f (GitHub-reviewed advisory GHSA-vhh6-v828-x62f lists affected ranges: npm @sap/approuter >=0 <23.0.0)

Commands are suggestions: review each one before running it.

Loading voting…