@jhb.software/payload-cloudinary-plugin: Arbitrary Cloudinary API Parameter Signing
CVE-2026-58200GHSA-h5x8-xp6m-x6q4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@jhb.software/payload-cloudinary-plugin 0.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @jhb.software/payload-cloudinary-plugin
- Affected
- >= 0.3.0, < 0.4.0
- Fixed in
- 0.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h5x8-xp6m-x6q4 lists affected ranges: npm @jhb.software/payload-cloudinary-plugin >=0.3.0 <0.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h5x8-xp6m-x6q4 lists affected ranges: npm @jhb.software/payload-cloudinary-plugin >=0.3.0 <0.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
- EPSS
- CVE-2026-58200: 0.31% estimated exploitation activity in the next 30 days; percentile 24.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Arbitrary Cloudinary API Parameter Signing in @jhb.software/payload-cloudinary-plugin Summary @jhb.software/payload-cloudinary-plugin v0.3.4 exposes a server-side signing endpoint (POST /api/cloudinary-generate-signature) that passes attacker-supplied paramsToSign directly to cloudinary.utils.apisignrequest() without any allowlist, key filtering, or policy enforcement. Any authenticated Payload user can obtain a cryptographically valid Cloudinary HMAC-SHA1 signature for arbitrary upload parameters — including overwrite=true, type=private, notificationurl, and path-traversal folder values — enabling unauthorized asset replacement, access-control bypass, and potential SSRF within the configured Cloudinary account. Details When clientUploads: true is configured, the plugin registers a signing handler at cloudinary/src/index.ts:74-79. The handler is implemented in cloudinary/src/getGenerateSignature.ts. Vulnerable code path (step by step): 1. cloudinary/src/index.ts:58 —…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-h5x8-xp6m-x6q4
- Revision 1 · created ·
Published from osv record GHSA-h5x8-xp6m-x6q4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-58200 Advisory: @jhb.software/payload-cloudinary-plugin: Arbitrary Cloudinary API Parameter Signing IDs: CVE-2026-58200, GHSA-h5x8-xp6m-x6q4 Record: https://patchnext.com/advisories/cve-2026-58200 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @jhb.software/payload-cloudinary-plugin 0.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @jhb.software/payload-cloudinary-plugin: affected >= 0.3.0, < 0.4.0; fixed in 0.4.0 ## Suggested inspection (read-only) - `npm ls @jhb.software/payload-cloudinary-plugin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @jhb.software/payload-cloudinary-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h5x8-xp6m-x6q4 (OSV record GHSA-h5x8-xp6m-x6q4 lists affected ranges: npm @jhb.software/payload-cloudinary-plugin >=0.3.0 <0.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-h5x8-xp6m-x6q4 (GitHub-reviewed advisory GHSA-h5x8-xp6m-x6q4 lists affected ranges: npm @jhb.software/payload-cloudinary-plugin >=0.3.0 <0.4.0) Commands are suggestions: review each one before running it.
Loading voting…