Skip to content

← Actionable
Medium, CVSS 5.5amended

ChatterBot: Symlink-Following Arbitrary Write via UbuntuCorpusTrainer

CVE-2026-58198GHSA-wvrh-2f4m-924v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (chatterbot 1.2.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-58198: 0.14% estimated exploitation activity in the next 30 days; percentile 3.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary ChatterBot's UbuntuCorpusTrainer.extract() uses a predictable, home-rooted output directory (~/ubuntudata/ubuntudialogs) with a check-then-create pattern (if not os.path.exists: os.makedirs) followed by tar.extractall(path=self.datapath). A local attacker who pre-plants a symlink at the predictable path causes os.path.exists() to return True (following the symlink), skipping makedirs, and subsequent extractall writes archive contents through the symlink to the attacker-chosen directory. The existing safeextract function validates tar member names (zip-slip defense) but does not validate the output directory itself — it cannot detect that self.datapath is a symlink. This is the defining distinction between the archiveextraction (zip-slip) and insecurefscreatetoctou families. Vulnerability Details Predictable output directory (line 535-546) Check-then-create (line 621-622) Extraction through symlink (line 633-644) safeextract calls os.path.abspath(directory) on self.datapath —…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wvrh-2f4m-924v

  2. Revision 1 · created ·

    Published from osv record GHSA-wvrh-2f4m-924v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-58198

Advisory: ChatterBot: Symlink-Following Arbitrary Write via UbuntuCorpusTrainer
IDs: CVE-2026-58198, GHSA-wvrh-2f4m-924v
Record: https://patchnext.com/advisories/cve-2026-58198 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: chatterbot 1.2.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI chatterbot: affected <= 1.2.13; fixed in 1.2.14

## Suggested inspection (read-only)
- `python -m pip show chatterbot`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on chatterbot.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wvrh-2f4m-924v (OSV record GHSA-wvrh-2f4m-924v lists affected ranges: PyPI chatterbot >=0 <1.2.14 (fixed))
- Verified: https://github.com/advisories/GHSA-wvrh-2f4m-924v (GitHub-reviewed advisory GHSA-wvrh-2f4m-924v lists affected ranges: PyPI chatterbot >=0 <=1.2.13)

Commands are suggestions: review each one before running it.

Loading voting…