Nightingale exposes datasource credentials to low-privilege users
CVE-2026-58167GHSA-27c6-wp53-387x
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/ccfos/nightingale/v6
- Affected
- < 6.7.3-0.20260528033214-762819fbaa23
- Fixed in
- 6.7.3-0.20260528033214-762819fbaa23
Go github.com/ccfos/nightingale/v4
- Affected
- every version
- Fixed in
- no fixed version recorded
Go github.com/ccfos/nightingale
- Affected
- every version
- Fixed in
- no fixed version recorded
Go github.com/ccfos/nightingale/v5
- Affected
- every version
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6638 lists affected ranges: Go github.com/ccfos/nightingale >=0; Go github.com/ccfos/nightingale/v4 >=0; Go github.com/ccfos/nightingale/v5 >=0; Go github.com/ccfos/nightingale/v6 >=0 <6.7.3-0.20260528033214-762819fbaa23 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-27c6-wp53-387x lists affected ranges: Go github.com/ccfos/nightingale/v6 >=0 <6.7.3-0.20260528033214-762819fbaa23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-58167: 0.41% estimated exploitation activity in the next 30 days; percentile 35.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Nightingale (n9e) before 9.0.0-beta.2 exposes full datasource configurations, including plaintext database passwords, HTTP bearer tokens, HTTP basic-auth passwords, and mTLS client keys, to any authenticated low-privilege (Standard role) user through POST /api/n9e/datasource/list. The route is registered without an admin authorization gate, unlike the sibling datasource mutation routes, and the open-source DatasourceFilter does not redact secret fields, so the secret-bearing settings, http, and auth objects are serialized in the response. The disclosed credentials enable access to the connected downstream systems.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-27c6-wp53-387x
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GO-2026-6638
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-58167 Advisory: Nightingale exposes datasource credentials to low-privilege users IDs: CVE-2026-58167, GHSA-27c6-wp53-387x Record: https://patchnext.com/advisories/cve-2026-58167 (revision 3, source checked 26 Oct 2026, 15:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/ccfos/nightingale/v6 6.7.3-0.20260528033214-762819fbaa23. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/ccfos/nightingale/v6: affected < 6.7.3-0.20260528033214-762819fbaa23; fixed in 6.7.3-0.20260528033214-762819fbaa23 - Go github.com/ccfos/nightingale/v4: affected every version - Go github.com/ccfos/nightingale: affected every version - Go github.com/ccfos/nightingale/v5: affected every version ## Suggested inspection (read-only) - Go github.com/ccfos/nightingale/v6: check the installed version with your package manager. - Go github.com/ccfos/nightingale/v4: check the installed version with your package manager. - Go github.com/ccfos/nightingale: check the installed version with your package manager. - Go github.com/ccfos/nightingale/v5: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/ccfos/nightingale/v6, github.com/ccfos/nightingale/v4, github.com/ccfos/nightingale, github.com/ccfos/nightingale/v5. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GO-2026-6638 (OSV record GO-2026-6638 lists affected ranges: Go github.com/ccfos/nightingale >=0; Go github.com/ccfos/nightingale/v4 >=0; Go github.com/ccfos/nightingale/v5 >=0; Go github.com/ccfos/nightingale/v6 >=0 <6.7.3-0.20260528033214-762819fbaa23 (fixed)) - Verified: https://github.com/advisories/GHSA-27c6-wp53-387x (GitHub-reviewed advisory GHSA-27c6-wp53-387x lists affected ranges: Go github.com/ccfos/nightingale/v6 >=0 <6.7.3-0.20260528033214-762819fbaa23) Commands are suggestions: review each one before running it.
Loading voting…