phpMyFAQ privilege escalation: GroupController::updatePermissions lets a GROUP_EDIT admin grant rights they do not hold
CVE-2026-57995GHSA-pg62-f8g4-4wqh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyfaq/phpmyfaq 4.1.5; thorsten/phpmyfaq 4.1.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmyfaq/phpmyfaq
- Affected
- <= 4.1.4
- Fixed in
- 4.1.5
Packagist thorsten/phpmyfaq
- Affected
- <= 4.1.4
- Fixed in
- 4.1.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pg62-f8g4-4wqh lists affected ranges: Packagist phpmyfaq/phpmyfaq >=0 =0 <4.1.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pg62-f8g4-4wqh lists affected ranges: Packagist phpmyfaq/phpmyfaq >=0 =0 <=4.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-57995: 0.44% estimated exploitation activity in the next 30 days; percentile 38.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview When phpMyFAQ hardened its admin permission-assignment endpoints against privilege escalation, it added a "a non-SuperAdmin may only assign rights they themselves hold" constraint to the user-rights endpoint (UserController::updateUserRights). The equivalent group-rights endpoint, GroupController::updatePermissions, did not receive that constraint. A delegated administrator holding only the GROUPEDIT permission can therefore grant any group an arbitrary set of rights — including rights the administrator does not possess — and, by being (or becoming) a member of that group, inherit those rights, escalating to higher privileges up to full administrative control. Impact phpMyFAQ supports delegated administration: the GROUPEDIT right can be granted to a non-SuperAdmin so they can manage groups. Such an administrator can escalate: 1. They call POST /admin/group/update/permissions with groupid set to a group they belong to (or can manage membership of) and grouprights[] containing…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pg62-f8g4-4wqh
- Revision 1 · created ·
Published from osv record GHSA-pg62-f8g4-4wqh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57995 Advisory: phpMyFAQ privilege escalation: GroupController::updatePermissions lets a GROUP_EDIT admin grant rights they do not hold IDs: CVE-2026-57995, GHSA-pg62-f8g4-4wqh Record: https://patchnext.com/advisories/cve-2026-57995 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmyfaq/phpmyfaq 4.1.5; thorsten/phpmyfaq 4.1.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmyfaq/phpmyfaq: affected <= 4.1.4; fixed in 4.1.5 - Packagist thorsten/phpmyfaq: affected <= 4.1.4; fixed in 4.1.5 ## Suggested inspection (read-only) - Packagist phpmyfaq/phpmyfaq: check the installed version with your package manager. - Packagist thorsten/phpmyfaq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmyfaq/phpmyfaq, thorsten/phpmyfaq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pg62-f8g4-4wqh (OSV record GHSA-pg62-f8g4-4wqh lists affected ranges: Packagist phpmyfaq/phpmyfaq >=0 =0 <4.1.5 (fixed)) - Verified: https://github.com/advisories/GHSA-pg62-f8g4-4wqh (GitHub-reviewed advisory GHSA-pg62-f8g4-4wqh lists affected ranges: Packagist phpmyfaq/phpmyfaq >=0 =0 <=4.1.4) Commands are suggestions: review each one before running it.
Loading voting…