phpMyFAQ has Potential Authenticated Path Traversal in PDF Export
CVE-2026-57961GHSA-88g4-74f3-63x9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyfaq/phpmyfaq 4.1.5; thorsten/phpmyfaq 4.1.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmyfaq/phpmyfaq
- Affected
- >= 4.0.0-alpha, <= 4.1.4
- Fixed in
- 4.1.5
Packagist thorsten/phpmyfaq
- Affected
- >= 4.0.0-alpha, <= 4.1.4
- Fixed in
- 4.1.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-88g4-74f3-63x9 lists affected ranges: Packagist thorsten/phpmyfaq >=4.0.0-alpha =4.0.0-alpha <4.1.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-88g4-74f3-63x9 lists affected ranges: Packagist thorsten/phpmyfaq >=4.0.0-alpha =4.0.0-alpha <=4.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-57961: 0.40% estimated exploitation activity in the next 30 days; percentile 34.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary There is an authenticated path traversal condition in the PDF export functionality, specifically within the PDF image resolution logic. The issue may allow a privileged FAQ editor to cause the application to attempt reading files outside the intended content directory during PDF generation. --- Affected Component File: src/phpMyFAQ/Export/Pdf/Wrapper.php Function: concatenatePaths() --- Root Cause The path resolution logic relies on locating the substring "content" within a user-controlled path: If "content" is not present, strpos() returns false, which becomes 0 when cast to an integer. As a result, the entire attacker-controlled path is preserved. Example: The resulting path is later processed by: without canonicalization or a root-directory containment check. --- Observed Data Flow --- Potential Impact Based on code review, a user with FAQ editing privileges may be able to store HTML containing crafted image paths that are processed during PDF generation. Potential…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-88g4-74f3-63x9
- Revision 1 · created ·
Published from osv record GHSA-88g4-74f3-63x9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57961 Advisory: phpMyFAQ has Potential Authenticated Path Traversal in PDF Export IDs: CVE-2026-57961, GHSA-88g4-74f3-63x9 Record: https://patchnext.com/advisories/cve-2026-57961 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmyfaq/phpmyfaq 4.1.5; thorsten/phpmyfaq 4.1.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmyfaq/phpmyfaq: affected >= 4.0.0-alpha, <= 4.1.4; fixed in 4.1.5 - Packagist thorsten/phpmyfaq: affected >= 4.0.0-alpha, <= 4.1.4; fixed in 4.1.5 ## Suggested inspection (read-only) - Packagist phpmyfaq/phpmyfaq: check the installed version with your package manager. - Packagist thorsten/phpmyfaq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmyfaq/phpmyfaq, thorsten/phpmyfaq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-88g4-74f3-63x9 (OSV record GHSA-88g4-74f3-63x9 lists affected ranges: Packagist thorsten/phpmyfaq >=4.0.0-alpha =4.0.0-alpha <4.1.5 (fixed)) - Verified: https://github.com/advisories/GHSA-88g4-74f3-63x9 (GitHub-reviewed advisory GHSA-88g4-74f3-63x9 lists affected ranges: Packagist thorsten/phpmyfaq >=4.0.0-alpha =4.0.0-alpha <=4.1.4) Commands are suggestions: review each one before running it.
Loading voting…