Skip to content

← Actionable
High, CVSS 7.4

Eclipse Jetty: Early return from the JASPIAuthenticator code can potentially no clear ThreadLocal variables

CVE-2026-5795GHSA-r7p8-xq5m-436c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.jetty.ee9:jetty-ee9-jaspi 12.1.8, 12.0.34; org.eclipse.jetty.ee8:jetty-ee8-jaspi 12.1.8, 12.0.34; org.eclipse.jetty.ee11:jetty-ee11-jaspi 12.1.8, 12.0.34; org.eclipse.jetty:jetty-jaspi 11.0.29, 10.0.29, 9.4.61; org.eclipse.jetty.ee10:jetty-ee10-jaspi 12.1.8, 12.0.34), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-r7p8-xq5m-436c lists affected ranges: Maven org.eclipse.jetty.ee11:jetty-ee11-jaspi >=12.1.0 =12.0.0 =12.1.0 =12.0.0 =12.1.0 =12.0.0 =12.1.0 =12.0.0 =11.0.0 =10.0.0 =9.4.0 <=9.4.60

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-5795: 0.53% estimated exploitation activity in the next 30 days; percentile 44.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description (as reported) A security vulnerability has been identified in Jetty's JaspiAuthenticator.java. The root cause is a failure to consistently clear authentication metadata stored in ThreadLocal during certain error or incomplete authentication flows. Specifically, after a GroupPrincipalCallback is persisted into the ThreadLocal, the authentication process may exit prematurely — before the ThreadLocal storage is cleared — if a mandatory CallerPrincipalCallback is missing or an exception occurs. This allows a subsequent, unprivileged user processed by the same worker thread to inherit these residual security roles, leading to Broken Access Control and Privilege Escalation. See also attached PDF. Impact An unauthenticated user may gain ungrated privileges from a previous request (privilege escalation). Patches No patches yet. Workarounds Do not use Jetty's JASPI.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r7p8-xq5m-436c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-5795

Advisory: Eclipse Jetty: Early return from the JASPIAuthenticator code can potentially no clear ThreadLocal variables
IDs: CVE-2026-5795, GHSA-r7p8-xq5m-436c
Record: https://patchnext.com/advisories/cve-2026-5795 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.eclipse.jetty.ee9:jetty-ee9-jaspi 12.1.8, 12.0.34; org.eclipse.jetty.ee8:jetty-ee8-jaspi 12.1.8, 12.0.34; org.eclipse.jetty.ee11:jetty-ee11-jaspi 12.1.8, 12.0.34; org.eclipse.jetty:jetty-jaspi 11.0.29, 10.0.29, 9.4.61; org.eclipse.jetty.ee10:jetty-ee10-jaspi 12.1.8, 12.0.34. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.eclipse.jetty.ee9:jetty-ee9-jaspi: affected >= 12.1.0, <= 12.1.7; >= 12.0.0, <= 12.0.33; fixed in 12.0.34, 12.1.8
- Maven org.eclipse.jetty.ee8:jetty-ee8-jaspi: affected >= 12.1.0, <= 12.1.7; >= 12.0.0, <= 12.0.33; fixed in 12.0.34, 12.1.8
- Maven org.eclipse.jetty.ee11:jetty-ee11-jaspi: affected >= 12.1.0, <= 12.1.7; >= 12.0.0, <= 12.0.33; fixed in 12.0.34, 12.1.8
- Maven org.eclipse.jetty:jetty-jaspi: affected >= 11.0.0, <= 11.0.28; >= 10.0.0, <= 10.0.28; >= 9.4.0, <= 9.4.60; fixed in 11.0.29, 10.0.29, 9.4.61
- Maven org.eclipse.jetty.ee10:jetty-ee10-jaspi: affected >= 12.1.0, <= 12.1.7; >= 12.0.0, <= 12.0.33; fixed in 12.0.34, 12.1.8

## Suggested inspection (read-only)
- Maven org.eclipse.jetty.ee9:jetty-ee9-jaspi: check the installed version with your package manager.
- Maven org.eclipse.jetty.ee8:jetty-ee8-jaspi: check the installed version with your package manager.
- Maven org.eclipse.jetty.ee11:jetty-ee11-jaspi: check the installed version with your package manager.
- Maven org.eclipse.jetty:jetty-jaspi: check the installed version with your package manager.
- Maven org.eclipse.jetty.ee10:jetty-ee10-jaspi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.eclipse.jetty.ee9:jetty-ee9-jaspi, org.eclipse.jetty.ee8:jetty-ee8-jaspi, org.eclipse.jetty.ee11:jetty-ee11-jaspi, org.eclipse.jetty:jetty-jaspi, org.eclipse.jetty.ee10:jetty-ee10-jaspi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r7p8-xq5m-436c (GitHub-reviewed advisory GHSA-r7p8-xq5m-436c lists affected ranges: Maven org.eclipse.jetty.ee11:jetty-ee11-jaspi >=12.1.0 =12.0.0 =12.1.0 =12.0.0 =12.1.0 =12.0.0 =12.1.0 =12.0.0 =11.0.0 =10.0.0 =9.4.0 <=9.4.60)

Commands are suggestions: review each one before running it.

Loading voting…