agent-coderag: Gradle Wrapper Execution During Dependency Discovery Enables Arbitrary Code Execution
CVE-2026-57586GHSA-wg5p-8h9p-3mr7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (agent-coderag 1.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI agent-coderag
- Affected
- <= 1.3.0
- Fixed in
- 1.3.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wg5p-8h9p-3mr7 lists affected ranges: PyPI agent-coderag >=0 <1.3.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wg5p-8h9p-3mr7 lists affected ranges: PyPI agent-coderag >=0 <=1.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-57586: 0.21% estimated exploitation activity in the next 30 days; percentile 11.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Gradle Wrapper Execution During Dependency Discovery Enables Arbitrary Code Execution Summary agent-coderag unconditionally executes a repository-controlled gradlew script during its default sync dependency-discovery flow. An attacker who can induce a victim to index a malicious Gradle repository (one containing build.gradle and a crafted gradlew) achieves arbitrary code execution with the victim's OS privileges. No authentication, no extra flags, and no elevated permissions are required; the attack fires on the default agent-coderag sync <path invocation. Details The vulnerability exists across a four-step call chain in the sync command: 1. Entry point — coderag/entry/cli.py:70 syncdependencies() is called unconditionally before indexing. There is no opt-in flag; any agent-coderag sync invocation triggers dependency discovery. 2. Gradle project detection — coderag/core/manager.py:40-47 The presence of a build.gradle or build.gradle.kts file in the target directory is sufficient to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wg5p-8h9p-3mr7
- Revision 1 · created ·
Published from osv record GHSA-wg5p-8h9p-3mr7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57586 Advisory: agent-coderag: Gradle Wrapper Execution During Dependency Discovery Enables Arbitrary Code Execution IDs: CVE-2026-57586, GHSA-wg5p-8h9p-3mr7 Record: https://patchnext.com/advisories/cve-2026-57586 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: agent-coderag 1.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI agent-coderag: affected <= 1.3.0; fixed in 1.3.1 ## Suggested inspection (read-only) - `python -m pip show agent-coderag`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on agent-coderag. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wg5p-8h9p-3mr7 (OSV record GHSA-wg5p-8h9p-3mr7 lists affected ranges: PyPI agent-coderag >=0 <1.3.1 (fixed)) - Verified: https://github.com/advisories/GHSA-wg5p-8h9p-3mr7 (GitHub-reviewed advisory GHSA-wg5p-8h9p-3mr7 lists affected ranges: PyPI agent-coderag >=0 <=1.3.0) Commands are suggestions: review each one before running it.
Loading voting…