Skip to content

← Actionable
High, CVSS 7.5amended

MessagePack for Python: Out-of-bounds read / crash on Unpacker reuse after a caught error

CVE-2026-57585GHSA-6v7p-g79w-8964

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (msgpack 1.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI msgpack

    Affected
    <= 1.2.0
    Fixed in
    1.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-57585: 0.49% estimated exploitation activity in the next 30 days; percentile 42.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact If the Unpacker is used repeatedly after an error occurs, the process may crash with a SEGV. If the Unpacker is used repeatedly to unpack untrusted input from external sources, it may be vulnerable to a DoS attack. Patches v1.2.1 Workarounds Users should create a new Unpacker instead of reusing the same Unpacker after an error occurs. Applying the above patch can prevent SEGV, but reusing the Streaming Unpacker after it has encountered an error will not yield correct data. If an error occurs during Streaming Unpacking, the Stream and Streaming Unpacker should be discarded. Therefore, this is not just a workaround but the correct solution. The above patch only prevents crashes from incorrect usage.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6v7p-g79w-8964

  2. Revision 1 · created ·

    Published from osv record GHSA-6v7p-g79w-8964

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57585

Advisory: MessagePack for Python: Out-of-bounds read / crash on Unpacker reuse after a caught error
IDs: CVE-2026-57585, GHSA-6v7p-g79w-8964
Record: https://patchnext.com/advisories/cve-2026-57585 (revision 2, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: msgpack 1.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI msgpack: affected <= 1.2.0; fixed in 1.2.1

## Suggested inspection (read-only)
- `python -m pip show msgpack`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on msgpack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6v7p-g79w-8964 (OSV record GHSA-6v7p-g79w-8964 lists affected ranges: PyPI msgpack >=0 <1.2.1 (fixed))
- Verified: https://github.com/advisories/GHSA-6v7p-g79w-8964 (GitHub-reviewed advisory GHSA-6v7p-g79w-8964 lists affected ranges: PyPI msgpack >=0 <=1.2.0)

Commands are suggestions: review each one before running it.

Loading voting…