Skip to content

← Actionable
Low, CVSS 3.3amended

OpenZeppelin Contracts Wizard: Line terminators in info.securityContact / info.license can inject lines into generated source

CVE-2026-57583GHSA-9wxg-vf3r-56hc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openzeppelin/wizard-stylus 0.3.1; @openzeppelin/wizard-stellar 0.6.2; @openzeppelin/wizard-cairo 3.0.1; @openzeppelin/wizard 0.10.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.3 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-57583: 0.19% estimated exploitation activity in the next 30 days; percentile 8.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Contracts Wizard generators printed info.securityContact and info.license verbatim into a single-line comment of the generated Solidity, Cairo, Stellar/Soroban, and Stylus source without rejecting line terminators. A newline (\n or \r\n) in either field ends the comment, so the text after it is emitted as source rather than remaining inside the comment — allowing arbitrary declarations to be injected into the generated contract. Impact This only matters when these fields are filled from input other than the user who will use the generated contract. Normal self-service use does not meet that condition: - Web app, AI assistant, and CLI: the user supplies these fields and uses their own output, so a line break only affects their own contract. (These fields are not URL-derived, so shared links cannot set them.) - Self-hosted API: same — the end user supplies the options and consumes the result. The case that matters is an integration that fills these fields from untrusted…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9wxg-vf3r-56hc

  2. Revision 1 · created ·

    Published from osv record GHSA-9wxg-vf3r-56hc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-57583

Advisory: OpenZeppelin Contracts Wizard: Line terminators in info.securityContact / info.license can inject lines into generated source
IDs: CVE-2026-57583, GHSA-9wxg-vf3r-56hc
Record: https://patchnext.com/advisories/cve-2026-57583 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @openzeppelin/wizard-stylus 0.3.1; @openzeppelin/wizard-stellar 0.6.2; @openzeppelin/wizard-cairo 3.0.1; @openzeppelin/wizard 0.10.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @openzeppelin/wizard-stylus: affected <= 0.3.0; fixed in 0.3.1
- npm @openzeppelin/wizard-stellar: affected <= 0.6.1; fixed in 0.6.2
- npm @openzeppelin/wizard-cairo: affected <= 3.0.0; fixed in 3.0.1
- npm @openzeppelin/wizard: affected <= 0.10.10; fixed in 0.10.11

## Suggested inspection (read-only)
- `npm ls @openzeppelin/wizard-stylus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @openzeppelin/wizard-stellar --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @openzeppelin/wizard-cairo --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @openzeppelin/wizard --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @openzeppelin/wizard-stylus, @openzeppelin/wizard-stellar, @openzeppelin/wizard-cairo, @openzeppelin/wizard.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9wxg-vf3r-56hc (OSV record GHSA-9wxg-vf3r-56hc lists affected ranges: npm @openzeppelin/wizard >=0 =0 =0 =0 <0.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-9wxg-vf3r-56hc (GitHub-reviewed advisory GHSA-9wxg-vf3r-56hc lists affected ranges: npm @openzeppelin/wizard >=0 =0 =0 =0 <=0.3.0)

Commands are suggestions: review each one before running it.

Loading voting…