plone.app.dexterity has a Denial of Service due to excessive title or description length
CVE-2026-57576GHSA-5426-92w4-wvhv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (plone-app-dexterity 5.0.1, 4.1.3, 3.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI plone-app-dexterity
- Affected
- >= 5.0.0, <= 5.0.0>= 4.0.0, <= 4.1.2<= 3.2.2
- Fixed in
- 4.1.3, 5.0.1, 3.2.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5426-92w4-wvhv lists affected ranges: PyPI plone-app-dexterity >=5.0.0 =4.0.0 =0 <=3.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5426-92w4-wvhv lists affected ranges: PyPI plone-app-dexterity >=5.0.0 =4.0.0 =0 <3.2.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-57576: 0.76% estimated exploitation activity in the next 30 days; percentile 55.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When creating content with a very large title or description field, Plone can become unresponsive. Even if the content loads, it can be hard to edit or delete, because the UI is unwieldy. Patches The problem has been patched in plone.app.dexterity. On Plone 6.2, upgrade to plone.app.dexterity 5.0.1. On Plone 6.1, upgrade to plone.app.dexterity 4.1.3. On Plone 6.0, upgrade to plone.app.dexterity 3.2.3. Another part of this problem has been patched in plone.app.contenttypes. See this advisory. Workarounds There are no known workarounds. This problem was responsibly reported by Aldin Visnjic to the Plone/Zope Security Team. Thank you! Note: The Plone/Zope Security team felt that the kind of fixes that were needed could be disruptive in corner cases if they were not careful. So they decided to develop the fixes publicly, giving the whole community the chance the review, and giving them the benefit from early feedback.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5426-92w4-wvhv
- Revision 2 · amended ·
Amended from osv record GHSA-5426-92w4-wvhv
- Revision 1 · created ·
Published from ghsa record GHSA-5426-92w4-wvhv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57576 Advisory: plone.app.dexterity has a Denial of Service due to excessive title or description length IDs: CVE-2026-57576, GHSA-5426-92w4-wvhv Record: https://patchnext.com/advisories/cve-2026-57576 (revision 3, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: plone-app-dexterity 5.0.1, 4.1.3, 3.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI plone-app-dexterity: affected >= 5.0.0, <= 5.0.0; >= 4.0.0, <= 4.1.2; <= 3.2.2; fixed in 4.1.3, 5.0.1, 3.2.3 ## Suggested inspection (read-only) - `python -m pip show plone-app-dexterity`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on plone-app-dexterity. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5426-92w4-wvhv (GitHub-reviewed advisory GHSA-5426-92w4-wvhv lists affected ranges: PyPI plone-app-dexterity >=5.0.0 =4.0.0 =0 <=3.2.2) - Verified: https://osv.dev/vulnerability/GHSA-5426-92w4-wvhv (OSV record GHSA-5426-92w4-wvhv lists affected ranges: PyPI plone-app-dexterity >=5.0.0 =4.0.0 =0 <3.2.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…