Laravel Backpack CRUD: HasMany/MorphMany relation fields allow cross-tenant record re-parenting (IDOR) via attachManyRelation
CVE-2026-57570GHSA-42vx-43vc-x6pr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (backpack/crud 7.0.47, 6.8.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist backpack/crud
- Affected
- >= 7.0.0, < 7.0.47>= 6.0.0, < 6.8.15
- Fixed in
- 6.8.15, 7.0.47
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-42vx-43vc-x6pr lists affected ranges: Packagist backpack/crud >=7.0.0 =6.0.0 <6.8.15 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-42vx-43vc-x6pr lists affected ranges: Packagist backpack/crud >=7.0.0 =6.0.0 <6.8.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-57570: 0.44% estimated exploitation activity in the next 30 days; percentile 38.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Vulnerability Details Affected area: HasMany / MorphMany relation handling during CRUD create and update operations CWE: CWE-862 — Missing Authorization Severity: Medium CVSS: 6.5 — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N Summary Backpack CRUD contained an authorization issue in the way certain HasMany and MorphMany relationship fields were processed during create and update operations. When an admin form allowed users to manage multiple related records, Backpack could update related model records based on submitted primary keys without sufficiently checking whether those records were eligible to be associated with the current parent model. This could allow an authenticated, low-privileged admin user to affect related records outside the intended authorization or tenancy boundary, if the affected CRUD form exposed this type of relationship field. Root Cause The vulnerable logic processed submitted relationship values and updated matching related records without consistently…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-42vx-43vc-x6pr
- Revision 1 · created ·
Published from osv record GHSA-42vx-43vc-x6pr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57570 Advisory: Laravel Backpack CRUD: HasMany/MorphMany relation fields allow cross-tenant record re-parenting (IDOR) via attachManyRelation IDs: CVE-2026-57570, GHSA-42vx-43vc-x6pr Record: https://patchnext.com/advisories/cve-2026-57570 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: backpack/crud 7.0.47, 6.8.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist backpack/crud: affected >= 7.0.0, < 7.0.47; >= 6.0.0, < 6.8.15; fixed in 6.8.15, 7.0.47 ## Suggested inspection (read-only) - Packagist backpack/crud: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on backpack/crud. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-42vx-43vc-x6pr (OSV record GHSA-42vx-43vc-x6pr lists affected ranges: Packagist backpack/crud >=7.0.0 =6.0.0 <6.8.15 (fixed)) - Verified: https://github.com/advisories/GHSA-42vx-43vc-x6pr (GitHub-reviewed advisory GHSA-42vx-43vc-x6pr lists affected ranges: Packagist backpack/crud >=7.0.0 =6.0.0 <6.8.15) Commands are suggestions: review each one before running it.
Loading voting…