justhtml: Mutation XSS with custom foreign-namespace sanitization policies
CVE-2026-5751GHSA-r758-8hxw-4845
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (justhtml 1.14.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI justhtml
- Affected
- >= 1.13.0, < 1.14.0
- Fixed in
- 1.14.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r758-8hxw-4845 lists affected ranges: PyPI justhtml >=1.13.0 <1.14.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r758-8hxw-4845 lists affected ranges: PyPI justhtml >=1.13.0 <1.14.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-5751: 0.26% estimated exploitation activity in the next 30 days; percentile 18.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A parser-differential / mutation XSS issue was found in justhtml when using a custom sanitization policy that preserves foreign namespaces such as SVG or MathML. Under these custom settings, specially crafted input could sanitize into HTML that looked safe at first, but became unsafe when parsed again by a browser or another HTML parser. Impact This issue does not affect the default safe configuration. You may be affected if you use a custom SanitizationPolicy with settings like: - dropforeignnamespaces=False - allowlisted foreign elements such as MathML or SVG - allowlisted raw-text containers such as <style In that case, an attacker could inject markup that survives sanitization and turns into active HTML after re-parsing. Affected versions - justhtml <= 1.13.0 Fixed version - Fixed in 1.14.0 Workarounds Until you upgrade: - keep dropforeignnamespaces=True - avoid allowlisting foreign namespaces for untrusted input - avoid allowlisting raw-text containers such as <style in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-r758-8hxw-4845
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-r758-8hxw-4845
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-5751 Advisory: justhtml: Mutation XSS with custom foreign-namespace sanitization policies IDs: CVE-2026-5751, GHSA-r758-8hxw-4845 Record: https://patchnext.com/advisories/cve-2026-5751 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: justhtml 1.14.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI justhtml: affected >= 1.13.0, < 1.14.0; fixed in 1.14.0 ## Suggested inspection (read-only) - `python -m pip show justhtml`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on justhtml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r758-8hxw-4845 (OSV record GHSA-r758-8hxw-4845 lists affected ranges: PyPI justhtml >=1.13.0 <1.14.0 (fixed)) - Verified: https://github.com/advisories/GHSA-r758-8hxw-4845 (GitHub-reviewed advisory GHSA-r758-8hxw-4845 lists affected ranges: PyPI justhtml >=1.13.0 <1.14.0) Commands are suggestions: review each one before running it.
Loading voting…